Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When Updating the look of the page, any update to the translated page is not working. The shortcode_css is being pulled from the original language. This is causing issues on the design of the local pages since the class names are different on the original and translations. But if you preview the translated page the CSS is working.

Solution: All you have to do is set the _wpb_shortcodes_custom_css meta to Don't translate. You can do this by going to WPML → Settings → Custom Term Meta Translation and pressing the Show system fields links. Now, just search for the meta and set it as suggested. From now on, when you create a new page, the CSS will be independent on the translated page, if you edit it manually.

Relevant Documentation: https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Patrick Cruz 10 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
June 12, 2020 at 3:49 am #6355977

Patrick Cruz

When Updating the look of the page, any update to the translated page is not working. The shortcode_css is being pulled from the original language. This is causing issues on the design of the local pages since the class names are different on the original and translations. BUT if you preview the translated page the CSS is working.

Any reason for this? I have multiple installs of WPML on multiple servers with different versions and it has the same issue. I only noticed this after the 5.4.2 update. but even if I downgrade to 5.4.1 the issue is still there.

I also noticed that when saving the translated pages the meta information is not updating on the DB. the only way it update is when I update the original page. I know you have settings to synchronize things, like templates. is this something that you're synchronizing as well recently? the meta key is: _wpb_shortcodes_custom_css

thanks. hoping this get fix soon as the site will get worst everyday.

June 14, 2020 at 8:34 am #6366985

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

Thank you for reaching out to the WPML support!

As I can see, you're using the WP Rocket plugin on your website. Can you deactivate the caching and see if the style is still not working as expected, please? Also, if you have any CSS minifying option active on your website, you can try to deactivate them too.

Have you tried to change the settings for the _wpb_shortcodes_custom_css, like changing it not to be translatable?

If none of these changes are working, please give me access to the dashboard area and I'll have a closer look at this. Also, please give me a link to the page where the CSS is not working as expected (so I can make sure that I'm checking the right element).

Thanks,
Radu

June 16, 2020 at 1:29 pm #6383791

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

Can you check this page now, please?
hidden link

As you can see, I was able to change the background of the first slider to be blue, while the color on the English page is still gray. Can you tell me if this is the kind of change that you were trying to make and it didn't work?

Thanks,
Radu

June 16, 2020 at 4:49 pm #6385791

Patrick Cruz

Sorry. I can see that the CSS are now working on this page?

hidden link

anything you changed?

June 16, 2020 at 5:40 pm #6386129

Patrick Cruz

Whatever you did worked!!! Please let me know how I can make the same fix for our production site.

Thanks so much!!!

June 16, 2020 at 5:57 pm #6386263

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patrick,

I'm glad to hear that everything works as you want now ^_^

I didn't change anything else, since my last massage. However, I set the _wpb_shortcodes_custom_css field to not be translatable. This way, the value for the translated page will be independent on each page.

I'll mark this ticket as resolved. If you have any other issue or maybe a quick question, feel free to open a new ticket and we'll take care of it in no time.

Regards,
Radu

June 16, 2020 at 6:01 pm #6386303

Patrick Cruz

Radu, Where is this setting?

June 16, 2020 at 6:13 pm #6386361

Patrick Cruz

I found it... so dumb... thanks!

My issue is resolved now. Thank you!