This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 3 voices.

Last updated by Robert 4 years, 6 months ago.

Assigned support staff: Robert.

Author Posts
November 28, 2014 at 1:05 pm #519646

edwardL-3

Okay, i will install that.

Yes, the problem persists, I'll duplicate it and let you know.

Just ran into a problem, i reactivated WPML, and it looks like it wasn't including all the articles that we added while the plugin was disabled.

November 28, 2014 at 3:18 pm #519730

Robert

Hey Edward,

Sorry for the trouble, I will do my best to help you. When you say
[php] i reactivated WPML, and it looks like it wasn't including all the articles that we added while the plugin was disabled.[php]
Do you mean in the duplicator file? The database records of translations remain in place even with WPML deactivated.

For us to better understand and possibly debug the issue it would be best to have a duplicate testing site setup in the same environment. If we create a local version we may not be able to recreate the problem, please let me me know if this is possible.

I also noticed that you PHP memory limit is set to 128M. Can you please increase this and check to see if the issue persists?

I would also suggest upgrading the server to PHP 5.4 -Newer PHP versions have an extra parameter to limit the "nesting level". Note - Please make backups before changing server settings

For reference, here are some articles for optimizing WPML
+ http://wpml.org/2012/01/can-your-site-run-faster/
+ http://wpml.org/faq/how-to-optimize-mysql-queries/
+ http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Thanks,
Robert

November 29, 2014 at 1:49 am #519928

edwardL-3

Hi, that was without duplicator. I meant, I had WPML disabled all this time, and during this time we've had hundreds of posts. So when I reactivated them, I'm guessing WPML didn't include those posts as "Traditional Chinese", so they didn't show up. Any way to fix that before activate WPML?

That's a problem I need to fix before I try anything else. Thanks!

December 1, 2014 at 2:56 pm #520768

edwardL-3

Hi, as per the question, i can't activate WPML unless I can fix the issue where the posts not set to any language don't show. We can't have an outage on our service during the mean time. how do we fix that?

December 1, 2014 at 2:58 pm #520770

Robert

If WPML is disabled and then you add a post, then reactivate WPML. The post will still be available in WordPress under the default language. Is your default language simplified Chinese?

December 1, 2014 at 3:06 pm #520777

edwardL-3

Yes it is, but when I reactivated it, all the newer posts were all gone, completely.

December 2, 2014 at 8:57 am #521235

Robert

I would recommend that you turn off all non WPML plugins and you revert to a default theme (like Twenty-Twelve) and check that the issue still exists? Your theme and a few plugins are not listed on our compatibility lists: http://wpml.org/documentation/plugins-compatibility/ and here: http://wpml.org/documentation/theme-compatibility/

As you mentioned that this was not possible on the live site it would be best to set up a duplication of the site in order to further test on.

December 2, 2014 at 9:01 am #521238

edwardL-3

I had to reset WPML to fix it.

I upgraded to PHP5.4, and it looks like it's slightly faster now. Just a question though, is WPML supposed to add load to Mysql?

I'm actually dealing w/ other CPU load surges, so I need to re-evaluate WPML's speed after fixing the other issue.

December 2, 2014 at 2:47 pm #521636

edwardL-3

Actually, it's very strange, and it's becoming very very serious. Now every time I update any posts, the load gets very high. This happened after I reactivated WPML.

Is there anything WPML could have done to the DB that could be causing this? I already deactivated WPML, but still seeing this issue.

December 3, 2014 at 2:18 pm #522441

Robert

As I recommended, it is imperative to do your debugging, testing and updates on a staging server to avoid interference on the public site and to save yourself stress. You should test that the theme, plugins to see if one perhaps is causing the issue. I would also recommend updating WordPress and other plugins. Did you also do a backup prior to resetting and making database changes?

Yes WPML will add extra content to load as there are extra considerations for language dependency, some extra load is expected. I also provided links for your review that suggest ways to optimize wpml performance in reduce mysql queries.

If WPML is reset, it will delete all language configuration set in the site and deactivate as if it was never installed, this shouldn't have any effect on other parts of the site.

Can you set a php debug javascript to true and check for errors? http://codex.wordpress.org/Debugging_in_WordPress

The topic ‘[Closed] WP-admin super slow after enabling WPML. Disable and immediately fast again.’ is closed to new replies.