Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 6 days, 15 hours ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 14, 2020 at 9:40 am #7006897

mattiR

I am able to run the initial import to get all the products to the store, but whenever I re-run the import i get an error where the server terminates the import process. Products are being updated daily, so this is a big problem to us. Screenshot: hidden link

September 14, 2020 at 10:31 am #7007303

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi, please let us know if this issue still happens if the "elemend_id" entry is fixed on your table. Thank You.

Best Regards
Marcel

September 15, 2020 at 1:28 am #7013539

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. I read all the issue description provided by my colleague Marcel, as soon as you have the results for the fix for the 'elemend_id' entry of your database tables, please, let me know, so, we can move forward in the issue resolution. Have a nice day.

September 15, 2020 at 9:28 am #7016565

mattiR

Applied the changes to the database, but the issue remains. I was first not able to get a new error message after it cuts off the import, but ran the import so many times, until it produced an error message.

Just in case, could you provide me with step-to-step instructions on the necessary changes to the database? This to rule out my process having the issue within itself.

Message below of the given error.

“Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPML Multilingual CMS.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.5.1
Current theme: Twenty Nineteen Child (version 1.6.1594974905) Current plugin: WPML Multilingual CMS (version 4.3.19) PHP version 7.4.10

Error Details
=============
An error of type E_ERROR was caused in line 32 of the file /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php. Error message: Uncaught InvalidArgumentException: element_id and type do not match for element_id:68274 the database contains post_product_variation while this function was called with post_product in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32
Stack trace:
#0 /wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1505): WPML_Set_Language->set(68274, 'post_product', false, 'en', NULL, true)
#1 /wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(337): SitePress->set_element_language_details(68274, 'post_product', false, 'en', NULL)
#2 /wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(181): WPML_Post_Translation->maybe_set_elid(false, 'product', 'en', 68274, NULL)
#3 /wp-content”

September 15, 2020 at 9:09 pm #7021403

mattiR

Further errors:

Fatal error: Uncaught InvalidArgumentException: element_id and type do not match for element_id:68274 the database contains post_product_variation while this function was called with post_product in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32

Stack Trace
1.
WPML_Set_Language->set(68274, 'post_product', false, 'en', NULL, true)
/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:1505
2.
SitePress->set_element_language_details(68274, 'post_product', false, 'en', NULL)
/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php:337
3.
WPML_Post_Translation->maybe_set_elid(false, 'product', 'en', 68274, NULL)
/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php:181
4.
/wp-content in /wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32

September 16, 2020 at 4:50 pm #7029935

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the migration process is done. Thanks.

September 16, 2020 at 5:11 pm #7029995

mattiR

Migration in process. Thanks for the help!

September 16, 2020 at 6:52 pm #7030403

mattiR

Migration has finished. Since we use Oxygen builder, i also logged in and re-signed all the shortcodes so the frontend works as well.

Please keep in mind, that this is a STAGING copy of the live site, where we are adding all the translated content, so if you figure out the cause we will need step-to-step instructions on how to replicate the fix once we push the changes to the live site. Thanks for your time and effort helping us out.

September 17, 2020 at 8:46 pm #7040553

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried some more troubleshooting in order to solve this issue, but unfortunately the issue persists, this is why I forwarded it to our second level support for a detailed look. I will update you here as soon as there's some updates about it. Thank you for your patience and understanding, have a nice day.

September 21, 2020 at 1:25 pm #7060253

mattiR

Any updates on this? We need to get the language versions published asap.

September 22, 2020 at 1:04 am #7063663

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the waiting. I checked our issue tracker and noticed we still don't have an update for this issue, I will update you here as soon as some more details are available. Thank you for your continued patience and understanding, have a nice day.

September 22, 2020 at 8:09 am #7065909

mattiR

Thanks for the reply. I also noticed on the main language (FINNISH) import: Once the cron triggers the import, the stock values are not updating correctly according to the feed either.

September 28, 2020 at 9:44 pm #7118841

mattiR

I would like to ask for an update on this ongoing issue?

September 29, 2020 at 2:08 pm #7125571

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the waiting here. I checked the reported issue in our issue tracker and unfortunately I still don't have an update for that, I see it is already assigned to one of our second level agents, so, as soon as they begin working on it an update will be available and I will confirm it here.

Sometimes due the nature of the issue, our team requires some extra time to invetigate it properly, and it seems to be your case here. Thank you for your continued patience and understanding, have a nice day.

October 1, 2020 at 12:24 pm #7143437

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience. After a database manipulation in the migrated website, where our second level support team deleted the entries for the element type error, I could run the import and it was completed properly. I asked for the detailed steps from our team, so we can apply the same for your website. I will update you here accordingly, have a nice day.