This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by gb-2 3 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
June 21, 2019 at 9:32 am #4065851

gb-2

Hello,
I've a multi language website structured with listingpro theme (website1).
Now I would like export all listings and import them in another multi language website always structured with listingpro theme (website 2).
I'm using the Wp All Import Addon for WPML to set correctly language.
Following the documentation (https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/) I go to import the Italian listings, and then import the english listings inserting the parent import (a common ID for each listing).
The import ends correctly, but the traductions is not connected.

June 21, 2019 at 5:18 pm #4068741

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

What are you using as the unique identifier column? This should be a separate column that you created in your import files that is specifically to link the columns.

If you would like to send me a copy of the files, I'll be happy to test the import on a staging site.

June 25, 2019 at 8:26 am #4082307

gb-2

Hello,
I'm using a tag naming "WPML Translation ID".
That are the english and the corresponding Italian files.
hidden link
hidden link

Thank you.

June 25, 2019 at 6:19 pm #4086667

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the files. I was able to resolve this by first deleting the empty row at the top of each of your files. This is because WP All Import uses the first row as the field IDs.

Next, I created a unique column for the ID instead of using WPML Translation ID. This is because each post will have its Translation ID created when it is imported, so i think trying to use this field would break the import.

You can see on my staging site here that I imported the files and they linked correctly:
One Click Login:hidden link
Username:demo
Password:vrNZV0Z738ke

Feel free to use this staging site for further testing if you need. Please let me know if you need any further assistance and I will be happy to help.

June 27, 2019 at 8:39 am #4098013

gb-2

Hello Lauren,
Thank you very much for your support.
I can't used a unique column for the ID instead of WPML Translation ID because I've send you a little part of my long excel files.
Each file consists of 300 lines with different order.
hidden link
hidden link
And in the column the unique common ID is WPML Translation ID.

Thank you so much.

Sara

June 27, 2019 at 1:13 pm #4100195

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Using the WPML Translation ID will not work because when a post/product is translated, a new translation ID is automatically created by WPML. As the documentation states, the files must contain a column with a unique ID in order for the translations to be linked when they are imported. https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#how-to-prepare-csv-xml-files

June 28, 2019 at 7:55 am #4105285

gb-2

Hello Lauren, thank you for your support.
I've tried to import the files that you've corrected.
But in my site don't work, the imported custom posts don't be connected.
I don't understand what I'm wronging! Can You look in my website?
Thank you.

June 28, 2019 at 4:30 pm #4109483

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure, I'll be happy to take a look. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

July 2, 2019 at 9:17 am #4125293

gb-2

My issue is resolved now. Thank you!