Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
September 2, 2020 at 4:58 pm

stefanop-18

All plugins installed and updated. Product imported but not connected.

September 2, 2020 at 6:13 pm
September 3, 2020 at 5:16 pm #6937345

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I downloaded the XML files and it seems they were not generated as explaioned here:

https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#how-to-prepare-csv-xml-files

Could you please verify? If the issue persists I can offer to create a test-site and we will try to recreate the issue but I would like to ask you to provide XML files as recommended in our documentation.

Also, would you be able to test if you got the same results when running only WPML, WP All Import and WooCommerce plus the needed add-ons for each plugin?

Kind regards
Andreas

September 8, 2020 at 2:02 pm #6966689

stefanop-18

Hi Andreas, thanks... I've tried several times, also with a really simple csv as in the image attached but still no results.... what can I try?

September 9, 2020 at 9:16 pm #6979523

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

The issue on your site seems realted to bad formated XML files or the applied workflow.

I have made now a test with the XML demo files froM WP All Import and I did not much more than adding the Connector column, giving each row a unique ID and ran the import while using the WooCommerce and WPML import options.

As unique connector I used only the connector column inside of the WPML import settings and in the last step of the WP Import progress.

The import worked almost without issues. The only issue was that the color attribute was displayed in both languages on the translated products.

Making a second import on minimal setup with Twenty Nineteen theme and only WooCommerce (updated), WPML and WP All Import did no longer show this issue which means the problem might occur due to another plugin.

If needed, we can investigate further on this behalf. I would suggest having all plugins updated first and then confirm if the issue persists.

Now, the test import included only variable products and if I recall correct you mentioned that you are using a mix of simple and variable products. I would suggest avoiding this. Make one import for each kind of product instead.

Could you please test again as explained above and adjust your XML files accordingly?

Kind regards
Andreas

September 21, 2020 at 2:26 pm #7060875

stefanop-18

Hi Andreas, I tried making an excel file with a new column called "wpml connector", but the problem is that I still have product imported in different languaged but not connected...

September 22, 2020 at 2:48 pm #7070871

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see one issue with your files.

You should create one file for each language.

One Italian file and one English file.

In your case you included columns for both languages inside the same file.

We need to make sure that the matching columns will get replaced when importing, as when we import with WP All Import we will only select one columns for each field.

This means both files need the exact same coloumns and in the second file you replace the product title, descriptions, taxonomies, etc. with the English text.

Do not inlude both language informations into the same file.

This should work out, as while testing on a new install I could not see any current compatilbity issues between WPML and WP All Import. Further, there is not any issue reported currently.

Let me know if you do have any further questions or need further assistance.

Kind regards
Andreas

The topic ‘[Closed] WP All Import – Products not connected’ is closed to new replies.