Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to have a correct visualization of a translated carousel.

Solution: Add the custom CSS to the style.css file so it can be loaded for all languages.

Relevant Documentation:

This topic contains 10 replies, has 2 voices.

Last updated by fulvioP 1 year, 6 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 11, 2018 at 10:01 am #2085712

fulvioP

I am trying to have a correct visualization of a translated carousel.

Link to a page where the issue can be seen: hidden link

I expected to see ike this : hidden link

Instead, I got: The carousel work but I dont see corners and arrows of the translated carousel.
Please check it

May 11, 2018 at 5:11 pm #2092968

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

The cause of this issue is that some CSS code is not loading for the secondary language. In order to solve this issue you need to use the lang pseudo selector in the CSS. In this link you will find more information regarding this pseudo selector: hidden link

I also recommend you to add this CSS to the styel.css file instead of doing it in a custom CSS area.

Kind regards,
Carlos

May 12, 2018 at 6:22 am #2096203

fulvioP

Hello Carlos,
can you write where and what I need to put to make the translation working please?
Thank you

May 14, 2018 at 7:55 am #2112414

fulvioP

can you help me please ?

May 14, 2018 at 11:47 am #2118103

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 14, 2018 at 4:02 pm #2124264

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I added the CSS code for the carousel to the style.css file. Please check the page and let me know if the issue is solved.

Best regards,
Carlos

May 14, 2018 at 4:07 pm #2124301

fulvioP

Hi,
no you can check the carousel in this page :

hidden link

let me know.
Thank you

May 14, 2018 at 4:50 pm #2124826

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I added the missing CSS code to the style.css file. Please check again the carousel and let me know if the issue is solved.

Note: Please flush the cache in your browser side by using Ctrl+F5 or Cmd+F5 in your browser. You can also visit the site in incognito mode.

Regards,
Carlos

May 15, 2018 at 9:00 am #2132492

fulvioP

Thank you Carlos for your support.
Now it works !

May 15, 2018 at 12:20 pm #2138489

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

May 21, 2018 at 9:24 am #2200070

fulvioP

Hello
Sorry but I see the same problem also in other page from my mobile like this one:
hidden link
Can you check please?