This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 28, 2019 at 5:49 pm #3909173

chiaraO

I am trying to: to translate a simple page, but most of the content isn't view by WPML and I don't know how to do.

Link to a page where the issue can be seen: hidden link italiano >> hidden link english

I expected to see: I need to see and traslate every fiels of backery composer.. even custom font etc..

Instead, I got: The page seems to be completed but it isn't...

May 29, 2019 at 12:56 am #3910697

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 29, 2019 at 6:08 pm #3918009

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details provided. Unfortunately I wasn't able to access your WordPress Dashboard, the provided access details doesn't seem to be correct. Can you please, review it? A private reply is enabled for you again, so you can send these details safely. Thank you for your collaboration, have a nice day.

June 3, 2019 at 8:15 pm #3945935

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and noticed your website is using some custom made WPBakery blocks (shortcodes) in these case, you would need no manually register these custom shortcodes to be translated with WPML using a specific XML code, here are the specific steps:

1 - In your WordPress Dashboard > Pages click to edit a page where you have missing page builder elements for translations and then click to 'classic' mode of your WPBakery editing screen in order to see the shortcode name, attributes and so on.

2 - Now in your WordPress Dashboard > WPML > Settings > Custom XML Configuration tab, enter the needed custom XML code to register your WPBakery shortcode for translations. For example, I registered your custom fonts shortcode with the following code:

 <shortcode>
      <tag>edgtf_custom_font</tag>
      <attributes>
          <attribute>content_custom_font</attribute>
      </attributes>
 </shortcode>

In the code above you can notice we are registering the 'content_custom_font'attribute from the 'edgtf_custom_font'. If you click to translate your page you will notice we have now the option to translate the Custom Font page builder block text content. You can repeat the same step for any WPBakery shortcode you don't see in the translation editor.

See: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

As an alternative method you can manually edit the translated page using the default WordPress page/post editor. Doing so, you don't need to register any page builder block/shortcode for translation. See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if it helps. Have a nice day.

June 12, 2019 at 9:50 am #4002685

chiaraO

Thank you for your support. I've tryied to use method 1 adding this code in my WPML > Settings > Custom XML configuration

<shortcode>
      <tag>edgtf_icon_list_item</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
</shortcode>

But Now I cannot see the WPML translation page where I could see intalian vs english fields...

June 12, 2019 at 12:20 pm #4004099

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In which page is it possible to see the issue happening? Also, please, make sure you are using the WPML Translation Editor to edit your page translation instead of using the default WordPress page/post editor. See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/. Please, let me know the results, have a nice day.

June 12, 2019 at 2:47 pm #4005457

chiaraO

Yes! It is the same page I was working on: Cosa facciamo - What we Do
if I force the WPML translator editor I cannot see the xml field I have already added...

hidden link

Again thank you so much for your help

June 13, 2019 at 2:33 pm #4013927

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. When registering a shortcode for translation using the XML code, you need to make a minor edit in the default language of the page where the shortcode appears (Cosa facciamo) in order to refresh the translation jobs and make the fields to appear in the WPML Translation Editor, I did that and now you are able to see the 'title' field from your 'edgtf_icon_list_item' shortcode ready to be translated. Please, let me know if you need any additional instructions or clarifications. Have a nice day.

June 13, 2019 at 4:50 pm #4015777

chiaraO

Sorry to bother you again. Now I have understoon what you mean.. But while I was trying to translate this page (hidden link), I've found that if I add a field in the XML file I cannot add a second one of the same block:

 <shortcode>
            <tag>edgtf_team</tag>
            <attributes>
                <attribute>team_name</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>edgtf_team</tag>
            <attributes>
                <attribute>team_position</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>edgtf_team</tag>
            <attributes>
                <attribute>team_description</attribute>
            </attributes>
        </shortcode>

What am I doing wrong?

June 13, 2019 at 6:07 pm #4016221

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. You don't need to enter the same shortcode tag in order to register the different attributes available, instead you can nest all the attributes under the same shortcode tag, so instead of:

       <shortcode>
           <tag>edgtf_team</tag>
           <attributes>
               <attribute>team_name</attribute>
           </attributes>
       </shortcode>
       <shortcode>
           <tag>edgtf_team</tag>
           <attributes>
               <attribute>team_position</attribute>
           </attributes>
       </shortcode>
       <shortcode>
           <tag>edgtf_team</tag>
           <attributes>
               <attribute>team_description</attribute>
           </attributes>
       </shortcode>

You can simply make the following:

       <shortcode>
           <tag>edgtf_team</tag>
           <attributes>
               <attribute>team_name</attribute>
               <attribute>team_position</attribute>
               <attribute>team_description</attribute>
           </attributes>
       </shortcode>

Please, don't forget to check our docs regarding it at: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Hope it helps, have a nice day.