This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Vincenzo Zollo 3 weeks, 5 days ago.

Assigned support staff: Jamal.

Author Posts
February 21, 2020 at 8:58 am #5538601

Vincenzo Zollo

Hello, I have the same issue as:
https://wpml.org/forums/topic/wpbakery-page-builder-media-grid-wpml-conflict/
but the solution provided did not work for me.

I have some images galleries, ie here: hidden link
but in the translated pages the images don't show: hidden link

I'm using the latest version of the WPML plugin and Media Translation plugin, I already duplicated the site images through WPML->Settings->Media Translation but they're still missing.
Note: when I edit the page using both the back-end or front-end wp bakery editor the images load perfectly fine!

Can someone help me please?

Thanks

Marta

February 21, 2020 at 3:58 pm #5542431

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Marta,

Thank you for contacting WPML Support. I will be glad to help with this.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal

February 27, 2020 at 4:30 pm #5579811

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Marta for your feedback. I confirm that the access information are working.

As this is a production site, I would prefer that you try the solution after a database backup. Please run Media Duplication in WPML->Settings->Media Translation. Check this reply https://wpml.org/forums/topic/wpbakery-page-builder-media-grid-wpml-conflict/#post-4341985

Let me know if this resolves the issue.

February 28, 2020 at 2:34 pm #5586195

Vincenzo Zollo

Hello Jamal,
I already did that but unfortunately it didn't solve the issue.

Marta

February 28, 2020 at 2:53 pm #5586401

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Maybe that's because you are not using the WPML Translation Management plugin which is required for WPBakery to work.
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Can you activate it and check if it resolves the issue. If it does not, please make a small update to the page and save it until you get the refresh icon on the translation and then update the translation.

February 28, 2020 at 3:26 pm #5586695

Vincenzo Zollo

Hi Jamal,

I still cannot see the images right, but now I can't see the translated text I already inserted for translated pages.. In the translation Manager I only see text in Italian for both italian and english/spanish languages!

February 28, 2020 at 3:37 pm #5586793

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I completed the translation to English and the gallery is now visible. Check hidden link

That worked also for the Spanish translation. Check hidden link

I am aware that I saved the Italian translation, but this resolves the issue.

Why is the Italian text on the translation editor for both Spanish and English? I think that mixing translations (translating with WPML Multilingual CMS, then with WPML Translation Management ) has created inconsistencies.

If you have a backup of the website, restore it. Open the Spanish and English translations on different windows. Then activate WPML Translation Management and translate again, that way you can copy/paste from the existing translations.

Please accept my apologies if my actions have made you lose your translations.

March 11, 2020 at 7:53 am #5660207

Vincenzo Zollo

Hello, thanks for your help, but I still have an issue: in this way (using WPML Translation Management), not all the fields are available for translation, so I cannot translate the website entirely! That is the reason why I was not using it!

EDIT: I have to use String Translation to translate certain texts.. but it is exhausting in this way 🙁

Marta