This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by lubaY 2 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 31, 2019 at 6:16 pm #4317257

lubaY

I am trying to:
Get only Spanish posts to display on the home page (Client Stories / Puntos destacados de nuestros clientes)

Link to a page where the issue can be seen:
hidden link

I expected to see:
3 boxes all Spanish

Instead, I got:
2 boxes in English, 1 Spanish

July 31, 2019 at 9:59 pm #4317737

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, follow the steps below:

- Click on the WPML > Settings > Post Types Translation
- On the "Posts", select the "Translatable - only show translated items" option
- Click on the Save button

After following these steps, refresh your home page again and see if the content is displaying correctly.

Thank you.

August 1, 2019 at 3:13 pm #4323371

lubaY

It was a combination of what you suggested plus I'd had "Excerpts" that were still in English so it was pulling the English in some cases. Thank you!