Due to the large volume of support requests, at the moment there is a waiting time of more than 24 hours. We apologize for the inconvenience this causes. We do not have any recurring unknown issues so we encourage you to please search the forum for other support topics that might be helpful and to review our documentation and look at our errata page for known issues. A supporter will respond to you as soon as possible.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices, and was last updated by  Amir 6 years, 10 months ago.

Author Posts
Author Posts
June 10, 2011 at 2:01 pm #29808


I am trying to use WPML with a wordpress installation which is a sub directory.
I do not wish to use the default permalink structure, as I am mainly using pages.
Tried using /%year%/%monthnum%/%postname%/ however, it wasn't accepting it.
Putting the install on the root would be the easiest but not the ideal scenario for me.
Please advice,

June 10, 2011 at 2:34 pm #29810

Forum moderator

"/%year%/%monthnum%/%postname%/" is the recommended permalink structure.
When you say that it's not accepting it, what do you mean? What error message are you seeing?

June 10, 2011 at 3:15 pm #29811


Thank you for replying so quickly Amir.
The HTACCESS file is there, as stated in your documentation.
On the language URL format I get in red "It looks like languages per directories will not function.".
Just to confirm, my installation is on domain.com/cms and not domain.com
Thank you again,

June 10, 2011 at 3:37 pm #29812

Forum moderator

That's fine. Our other website runs in a directory too and works without problems:
I suggest that you make the .htaccess file writable. Then, go to settings->permalinks, choose Year/Month/Name from the radio box (don't type it in manually) and save. This should refresh the .htaccess file. If you see a message about not being able to write to .htaccess, handle that first.
Then, go again to WPML->Languages.
Can you also share a link to your site, so that we can see what's going on there?

June 10, 2011 at 4:03 pm #29813


Ah, excellent 🙂 so trying to do the same thing.
.htacess is now 777 for testing purposes.
Permalinks is now hidden link
domain is hidden link
WP installation is hidden link
Still says "It looks like languages per directories will not function. Details"
We are getting there, thanks for your help.

June 10, 2011 at 4:12 pm #29814

Forum moderator

Well, I see that we're getting back a 404 error on your front page:
hidden link
This is what triggers the warning.
Add some content (at least one post) to all languages and test when it's not reporting 404 for the front page.

June 10, 2011 at 10:04 pm #29815


Amir, that 404 is because the index file is in the root and the wp installation is in the sub folder, when you go to the root, you don't get an error message, however, when you go directly into the installation folder it does.
I'll add the content per language and check it out 🙂
Thanks very much for all your help so far,

June 11, 2011 at 8:43 am #29816

Forum moderator

If you know that there are no content on the main blog page, you can just ignore that warning. WPML says that it looks like it's not going to work, but you can save the 'languages per directories' anyway.

The topic ‘[Closed] WP in sub directory, using WPML’ is closed to new replies.