This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't see the jobs in the secondary language

Solution: I solved the issue by changing the language URL format in WPML -> Languages -> Language URL format -> Selected 'Different languages in directories' option -> Re-saved the permalinks.

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 25, 2019 at 11:05 pm #4642239

robs-3

Tell us what you are trying to do?
After translation to englisch te link chnages from ../vacatures/.. into ../jobs/.. which results into a 404 error!

Is there any documentation that you are following?
Saw a solution in english but my menu is duch, so cannot find the right answer

Is there a similar example that we can see?

What is the link to your site?
hidden link

September 26, 2019 at 12:14 pm #4646685

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you describe the steps to reproduce the issue? Please attach some screenshots that help me to get a better understanding.

2.- Could you share the solution you found in English?

Kind regards,
Carlos

September 29, 2019 at 11:03 am #4660429

robs-3

Found the solution for the error of 404 in making specific links in the listing of job-manager.
See screenshot buit noe I haven to solve the problem why the jobs are not published in the main page where I put my code [jobs]?

If you need a admin login? Let me now

Kind regards,
Rob

September 30, 2019 at 9:42 am #4663397

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Rob,
Thank you very much for the information provided.

1.- Please provide step-by-step how to reproduce the issue in the site. Because I'm not fully clear of the issue.

2.- I have set your next message private and there you will find the fields to provide the credentials in a secure way.

Regards,
Carlos

September 30, 2019 at 1:46 pm #4665023

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I tried to access the login link but I get a 404 error. Could you double check that the staging site is working correctly?

Regards,
Carlos

September 30, 2019 at 5:03 pm #4666739

robs-3

Sorry the wp login must be:
hidden link

October 1, 2019 at 10:52 am #4671215

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your message.

I solved the issue by changing the language URL format in WPML -> Languages -> Language URL format -> Selected 'Different languages in directories' option -> Re-saved the permalinks.

Note: I also re-saved the test job in English.

Could you confirm that the issue is solved?
Regards,
Carlos

October 1, 2019 at 11:24 am #4671603

robs-3

My issue is resolved now. Thank you!

October 1, 2019 at 12:25 pm #4671969

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos