This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 6 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
March 10, 2019 at 7:46 am

mehmoodA

I am trying to:Show the wp resume fields plugin custom fields in arabic version but it is not showing only default fields are showing

Link to a page where the issue can be seen:Admin panel

I expected to see:I want to show the same fields which is in english version in arabic version with translation in arabic

Instead, I got:All fiedls not showing only default fields are showing (custom fields not showing)

March 11, 2019 at 9:28 am #3309119

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You wrote: "I am trying to:Show the wp resume fields plugin custom fields in arabic version but it is not showing only default fields are showing"

I assume that you are referring to the to 'repeater' fields or fields that hold 'serialized data' like gallery fields and taxonomy fields. Is it correct?

Please make sure that you are following our instructions for how to work with 'repeater' fields. You can see it here.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

If your issue is with 'serialized data' fields then we have a known issue with those fields. Please see it at the following link.
https://wpml.org/errata/issue-serialized-acf-fields-set-copy/
In this case, there a workaround that you can implement which is to set the fields to 'Translate' and provide the data for these fields manually, in the translations.

We also have the following known issue: 'Gutenberg blocks created using ACF 5.8 are not translatable'. If your case is related to this issue please read more about it at the following link.
https://wpml.org/errata/gutenberg-blocks-created-using-acf-5-8-are-not-translatable/

Please let me know if this information is helpful to you.

Regards,
Itamar.

March 11, 2019 at 10:10 am #3309589

mehmoodA

Thanks Itamar,

First thing is this is not the repeater fields.We are using wp job manager and its addon (Resume manager).THere are resumes fields where we can create the fields for the resume.When i am switching to arabic it only showing default field not all the fields which is in english version.

I want to show all the resume fields which are in english version into arabic with translation.

I have already sent you admin and ftp access.You can view those fields in left menu Resumes->Resume Fields.

Thanks

March 11, 2019 at 12:28 pm #3311155

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site. It seems that the _resume fields are all set to 'Don't translate'. Please see the attached screenshot. Here is what you need to do.

1. Edit one of your 'Resume' CTP.
2. Scroll down to the Multilingual Content Setup section.
3. Press the 'Show system fields' link.
4. Set all the related 'resume' fields (the one that you configured in Resume -> Resume Fields) to 'Translate'.
5. Save the settings.
6. Update the 'Resume' CPT.
7. Edit the translation of the CPT and see if you can translate those strings.
Alternatively, you can also set those fields to be translated in WPML -> Settings -> Custom Fields Translation.

Please also see our documentation about translating custom fields.
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Please let me know if this information is helping you to solve the problem.

Regards,
Itamar.

March 12, 2019 at 6:12 pm #3327367

mehmoodA

Hi,

Sir i have followed the all the options but still i am having problem.Let me explain you in detail

My site is in two languages first is English and second is arabic

I have create a form using the resume fields plugin eglish version of the form you can see here.

hidden link

This form i have created from admin here

hidden link

Now in arabic version frontend url of the form is

hidden link

and admin url where i am creating from

hidden link

You will see the form does not have same fields arabic version has less fields.So when i am trying to create fields for the arabic version it change the english version and voice versa.

DOn't know what is the problem

Thanks

March 13, 2019 at 3:43 pm #3335819

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site by trying to replicate the issue. But I'm not sure how to replicate it. The issue that you have with the resume fields is probably happening because that the WP Job Manager - Resume Manager plugin (hidden link) and its main plugin WP Job Manager (hidden link) are not compatible with WPML. You can find all of the compatible plugins here.
https://wpml.org/documentation/plugins-compatibility/

In this case, we need to replicate the issue on a clean WordPress installation. Then I'll be able to escalate this issue to our compatibility team, and they will see if they can find a fix for this issue. If not then we'll need to contact the developers of the plugin and cooperate with them on making the plugins compatible with WPML.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the WP Job Manager plugin and the WP Job Manager - Resume Manager plugin and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site. Please also make sure that you are installing the latest version of the plugin. If you can then replicate the issue also on the test site, please explain to me how to replicate the issue step by step. For example, I couldn't understand where is the form that you insert the resume fields in and how to insert them in the form.

Regards,
Itamar.

March 13, 2019 at 6:19 pm #3337217

mehmoodA

Hi Itamar,

I have installed the plugin and created a form for issue please visit the following url

hidden link

Resumes->Resume Fields

Now switch the language to arabic edit the first field "resume_id_number" and change the label to something "ID NUmber Arabic".Must remember that in english version this label was "ID number" and also in arabic but now we have changed it to "ID Number Arabic".

After saving switch the language from arabic to english you will see the label is also changed in english as well.THis is the problem label does not remaining different in both language change in one also changed in other.

Hope you will got the problem i am facing.

Thanks

March 14, 2019 at 6:50 pm #3348003

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for installing the plugin on our test site.

I could see the problem on the test site. I've also tried to translate the "resume_id_number" field label in WPML -> String Translation. It is available for translation there, but unfortunately, it does not work either. Therefore I've escalated this issue to our compatibility team, and they will try to find a fix for this. If our compatibility team is not able to fix this, they will need to contact the developers of the plugin. Then the progress of this fix will also be dependent on the developer cooperation with us.

I'll keep you updated here.

Thank you for your patience.
Itamar.

March 18, 2019 at 8:38 am #3366795

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

We have found that the field label is not changing into Arabic because the admin area is set to the English language. You can change it in Users -> Your Profile -> Language. If you set the language to Arabic and save and then go back to Resume you will see the field label in Arabic. It will stay in Arabic even if you change the language at the top admin bar. Changing the flag at the top admin bar only changes the editing language. But the strings of plugins (if translated) show the translation according to the language that is chosen in your profile.

Please let me know f the issue is cleat now.

Thanks,
Itamar.

March 27, 2019 at 2:23 pm #3471917

mehmoodA

THaks for the support .Now i can create the fields in both language but i am righ now using string translation for second language (arabic) but some of the fields label does not changing although i have changed all the instance of label in string translation.

hidden link

Here you will see following fields does not changing .
e.g

Job Type
Location

One thing i want to mention if i change the field label to "Job Type 1" then label can be change but not with Job type.

Thanks

March 28, 2019 at 4:05 pm #3483485

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This seems like a new issue. Strings are not showing the translation on the front-end.
But even if that is the case, I can't see those English strings (Job type, Location) on the page that you tell me it is happening. Please see the attached screenshot.
Have you fixed this problem already?

The topic ‘[Closed] Wp resume fields not showing in arabic version’ is closed to new replies.