Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 4 voices.

Last updated by Shekhar Bhandari 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
February 27, 2018 at 4:24 pm #1530791

John

I am trying to: -using wp rocket to cache whole website

Link to a page where the issue can be seen:all pages

I expected to see: normal behaviour

Instead, I got: need to refresh/change page multiple times to get the result

same issue like here: https://wpml.org/forums/topic/currency-switcher-dont-change-currency-when-site-is-cached-wp-rocket/

February 28, 2018 at 7:54 am #1531413

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to help you further on this issue.

I just checked the currency switcher on this page and it's switching properly. hidden link

So could you please provide me with a link along with its screenshots where the issue can be seen?

Also, If you disable all non-related WPML plugins except Wp-Rocket, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

February 28, 2018 at 7:49 pm #1532274

John

Hello,
Of course it is switiching perfectly because the wp rocket plugin is deactivated.
I have tried with 2 websites: 1 using handmade theme other using sash theme whenever wp rocket is activated the currency won't switch. You need to change the page for few times to get the selected currency.
I can't do tests on my live website.
But if you check this topic https://wpml.org/forums/topic/currency-switcher-dont-change-currency-when-site-is-cached-wp-rocket/
it is the same issue. As you can see it doesn't matter what theme are you using (That guy was using flatsome theme) wp rocket blocks the currency switcher.
I can give you a sandbox link if you want to test.
Just use handmade/flatsome or slash theme and you will see that currency won't switch immediatly.

March 1, 2018 at 7:27 am #1532609

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I can give you a sandbox link if you want to test.
Just use handmade/flatsome or slash theme and you will see that currency won't switch immediately.

Sure, this will be much helpful for me to test the issue further, I have enabled the private reply so you can send me a sandbox link to test this issue further.

Look forward to your reply.

Thanks

March 8, 2018 at 8:29 am #1540114

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I tested the issue on my browser and here are my results where the issue is not reproduced, so could you please test the issue in a new browser and let me know if the results are same. hidden link

Look forward to your reply.

Thanks

March 9, 2018 at 2:23 am #1541326

John

I don't know exactly what happened. But at the first this this wasn't working. Very strange.
Thanks for your support. Really appreciate it !

March 9, 2018 at 2:26 am #1541328

John

Actually i have tested on other website with handmade theme and the issue persists:
Here is a link: hidden link

March 9, 2018 at 2:31 am #1541330

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please send me the login details of the site where the issue is existing, so I can debug this issue further?

Enabled the private reply for you.

Thanks

March 9, 2018 at 9:55 pm #1542251

pierrep-17

Hello,

Same problem with my website:

hidden link

When wp rocket is activated, currency switcher does not work.

Thanks for your help.

March 14, 2018 at 9:25 am #1545589

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I can see the issue, to further debug this issue I would need to replicate the issue on my localhost so would you mind sending me wp-content and database backup files, you can zip these files and send me the files using google drive.

To send the link, you can edit your previous private reply.

Look forward to your reply.

Thanks

March 16, 2018 at 11:10 am #1547923

John

Edited

March 19, 2018 at 1:59 pm #1549652

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I tried to replicate the issue using the database backup file you provided but it seems the file contains errors as a reason I couldn't perform the debugging, so would you mind sending me the database backup file once again.

Look forward to your reply.

Thanks

March 19, 2018 at 2:05 pm #1549669

John

i've updated the private response

March 20, 2018 at 4:36 pm #1551277

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thanks for the details.

I am working on this issue and will respond to you soon.

Thanks

March 21, 2018 at 3:34 am #1551712

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just disabled/enabled the wp-rocket on your site and I can see that it's working properly, so it seems like there was some issue which is fixed disabling enabling it. Could you please monitor the issue for some time and let me know if the issue is fixed.

I checked the issue on this page: hidden link

Look forward to your reply.

Thanks