This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 5, 2019 at 3:00 pm #4341491

sanjeevK

Hi,

The wp_footer & <footer> elements are not showing up on my translated home

Default language: hidden link
English translated home page: hidden link

As you can see the default language has the footer html tag and also the default wp_footer element in it.

I am using ACF option page to display the content in the footer but I don't think the it's ACF/WPML integration issue because the wp_footer is not showing up with all the enqued scripts.

Can please help out to see what i am doing wrong?

Thanks
Sanjeev kana

August 5, 2019 at 7:22 pm #4342715

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Sanjeev,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 6, 2019 at 5:37 pm #4349801

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and could fix the issue, here are the steps I tried:

1 - In your WordPress Dashboard > Custom Fields I deleted the english translation of your 'home' field group.

2 - In your WordPress Dashboard > Settings > Post Types Translation I set the 'Field Groups (acf-field-group)' post type as 'not translatable'.

The reason for that is that actually you only need to add translations for the fields groups if you need to translate the fields labels and other interface descriptions which doesn't seem to be your case here. Also, it is a needed step to avoid any inconsistency in the fields across languages, for example a missing field in the field group translation.

See: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

3 - In your WordPress Dashboard > Pages I clicked to edit your homepage and added a duplication of this page to the english language. This step assure all the page content and markup is copied to the secondary page in order to avoid any missing section.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

4 - In your WordPress Dashboard > Settings > Reading I also set your 'home' page as the homepage of your website.

As the only step remaining you will need to setup your hero section again (the main content after the header) and customize the content of your english homepage to fit your needs.

Please, let me know if you need any additional step and clarification. Have a nice day.