This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by valentinaM-3 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 27, 2019 at 8:00 am

valentinaM-3

Hi,

I have a problem with string translation table.
I see this message on my dashboard:

'wp_icl_strings' is marked as crashed and last (automatic?) repair failed

Array
(
[language] => en
[context] => Cookie Notice
[gettext_context] =>
[domain_name_context_md5] => XXXXXXXXXXXXXXXXXXX
[name] => Message in the notice
[value] => This website uses cookies required to operate and useful for the purposes described in the cookie policy. If you want to know more about it click on the "Read more" button.
By closing this banner, scrolling this page, clicking on a link or continuing navigation in any other way, you consent to the use of cookies.
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)

And the string translation page is empty!
I tried to fix it following this workaround: https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/
but with no success.

I have to upgrade to WP 5.2.2. but the full backup I made has an issues in relation with the string table:
"Unable to execute SQL: Table 'wp_icl_strings' is marked as crashed and last (automatic?) repair failed"

Can you help me?

Thanks,
Valentina

June 27, 2019 at 8:31 am #4097947

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

The issue seems to be related to more of MySql database than WPML,
https://stackoverflow.com/questions/8843776/mysql-table-is-marked-as-crashed-and-last-automatic-repair-failed

Secure a backup of your database and files, try the fix suggested in this link https://stackoverflow.com/a/43893582/2247465

Please let me know the results.

Kind regards
Raja

July 10, 2019 at 6:16 am #4176263

valentinaM-3

Hi Raja,
sorry for my delay.

Yes, the problem was in the db, now is resolved!

Thanks again!