Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 2 years ago.

Assigned support staff: Bigul.

Author Posts
September 5, 2018 at 5:23 pm #2708365

FilippoZ1

Hello,
Our website got very slow and after some debug i find out that wp_icl_strings was about 30mb.
So i cleaned the table ( using the informations from this topic => https://wpml.org/forums/topic/how-to-find-delete-waiting-for-translations-strings/ ) and I unchecked all text-domains from the auto-registering.
But i still can see text-domains being added to the table in Database.

I am missing something to disable auto-registering ?

Thank you
Alex
Idearia.

September 6, 2018 at 6:04 am #2709614

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alex,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Theme and plugins localization and let me know your which option you have selected for *Localization options>>How to translate strings in themes and plugins*

Please select the string domains you need for translation from WPML>>String Translation>>Auto register strings for translation, then check is there any difference in the site performance. Because we have made a lot of changes in the string Translation to improve the performance. So Auto Adjust ID(WPML > Languages) and Auto register strings should be enabled.

--
Thanks!

Bigul

September 6, 2018 at 9:40 am #2710153

FilippoZ1

Hi Bigul, thank you for your reply

This are my settings:

1. WPML>>Theme and plugins localization - *How to translate strings in themes and plugins?*=> Translate themes and plugins using WPML's String Translation only (don't load .mo files). I saved again this setting to be sure.

2. WPML>>String Translation >> Auto register strings for translation => All the domains wer unchecked previously by me, now i just checked the one i need.

Actually i saw a lot of improvments in the site speed after i cleaned up the database

DELETE FROM wp_icl_strings WHERE status IN (1,0);

my wp_icl_strings was about 30mb after i run the query became 5mb (from ~20s of loading to less than ~3s).
I'm not really sure if this 2 settings changed something in the website speed.

My only fear is that this table start grow again; now as i can see after a navigation of the website with this 2 settings it didn't grow to much.

I will update you in the next days if the table start grow again or not.

In case this table start to grow again, do you think is ok if i add a cronjob to my server to run the delete query every night ?

Thank you,
Alex
Idearia.

September 6, 2018 at 4:09 pm #2711544

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alex,

Thank you for the feedback. I will consult about this with our second tier team for the expert opinions and get back to you. Please wait.

--
Thanks!

Bigul

September 7, 2018 at 7:15 am #2713342

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alex,

Normally wp_icl_strings table will only grows when we add the strings for translating(like installing new plugins,adding widgets and theme options etc...). Therefore please check is there any random strings are registering for String Translation or not(random values appended to some of the strings).

--
Thanks!

Bigul

The topic ‘[Closed] wp_icl_strings keeps being populated’ is closed to new replies.