This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Andreas W. 3 weeks, 5 days ago.

Assigned support staff: Andreas W..

Author Posts
August 19, 2019 at 4:40 pm #4417501

alexanderB-64

Hi, I updated WooCommerce products using WPAllImport and it is working well except product attributes are not reflected in the translation. The attributes will sync when I visit the edit product screen of the translation and hit update manually.

Other fields like price are showing immediately after import, the issue seems to apply only to product attributes.

Situation:

1) Products were created and translated. All product attributes and other taxonomies have been translated via the WooCommerce ML admin

2) Products were exported in the original language using WPAllExport

3) The exported sheets have been edited (e.g. adding product attributes)

4) The edited sheets are imported using WPAllImport to update products

5) Fields like price are immediately showing correctly in the original language and translation. Updated product attributes are showing correctly in the original language, but not in the translation. When I go to the edit screen of the translation and hit "Update" the translated attributes are showing.

How can I do the import without having to manually update each product?

Approaches so far:
- programmatically called wp_insert_post and $sitepress->copy_custom_fields on the translations during import, but did not work

August 20, 2019 at 2:50 am #4420117

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 20, 2019 at 6:39 pm #4426001

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Die Lösung für das Problem wäre wie folgt:

1) Gehen Sie auf Produkte
2) Markieren Sie die Checkbox für alle Produkte
3) Wählen Sie aus dem Dropdown Mehrfachaktionen "Bearbeiten" aus
4) Klicken Sie nun auf "Aktualisieren" ohne weitere Änderungen an den Prdukten.

Auf dieser Weise werden alle Produkte aktualisiert und die Attribute erscheinen übersetzt auf dem Front-End. Im Zweifel, gehen Sie bitte auf WPML -> Taxonomie-Übersetzung und synchronisieren Sie die vorhandenen Taxonomien. Die Option wird nur erscheinen, wenn eine Synchronisierung verfügbar ist.

Mit freundlichen Grüßen
Andreas