Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

WPBakery inline CSS gets ignored in translated pages if they are translated without WPML's Translation Editor.

Solution:

What you need to do is disconnect the translated page from the default language page. Then press the update button. And then reconnect the page to the default language.

Relevant Documentation:

https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 5 voices.

Last updated by Itamar 9 months ago.

Assigned support staff: Itamar.

Author Posts
June 12, 2020 at 12:00 pm #6359207

joonasV-2

Hollers!

I duplicate an page with wpml for translation and everything looks as they should. Funny part starts when/if I edit any WPBakery "elements" css settings (bgcolor, padding, margin etc.) of this duplicated/translated page. At this point wpml ignores all the inline(?) css I've made. If I disconnect this translated page of it's original language version everything is fine again and inline css read.

If I start the translated page from the scratch, it will ignore all the css I do with WPBakery "elements" from the very start. Only way to get these css working is to make a duplicate AND not touching it after this. Or to disconnect the translated page of it's original language page.

Ofcourse I can work this around and put all the customizing inside a css-file or WP's custom-css, but this is little bit against the idea of block editors? Plus language copies I'm working with are not exact copies of another.

Attached image is an sample of "WPBakery elements inline css settings" I am talking about. This is an example of duplicated settings from original language. They work until I touch any of these settings and wpml will ignore all of them.

So what am I missing? Some setting I guess?

Thanks in advance
Joonas

wpbakery-elements.png
June 14, 2020 at 7:55 pm #6368501

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Can you please confirm that you are following our instructions at the following link on how to work with WPML and the WPBakery Page Builder?
https://wpml.org/documentation/translating-your-contents/page-builders/

I also ask that because when I check the debug information of your site I can see that the Translation Management add-on is not active on your site. And when working with WPML and the WPBakery it is needed also to activate the Translation Management add-on.

Regards,
Itamar.

June 15, 2020 at 11:43 am #6373045

joonasV-2

Hi Itamar!

Using Tranlation Management add-on, is it possible to delete elements from the translation page as they are not exact copies from the original language? The structure of translated pages are very different comparing to original language but they appear as "translations".

Thanks in advance!

June 16, 2020 at 8:25 am #6380683

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

In my first reply, I didn't give the most correct link to our documentation about WPBakery so here it is.
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

You ask: "Using Tranlation Management add-on, is it possible to delete elements from the translation page as they are not exact copies from the original language?"

No, if you need different layout/structure in the other languages then please follow our documentation here.
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

You wrote: "The structure of translated pages are very different comparing to original language but they appear as "translations"."

I'm not sure what you are trying to achieve and what you mean by "appear as "translations".
WPML does have the option to display posts and pages in the other language and show them in the default language of the set. We call it "Display as translated." The purpose of this option is to enabled our users to display all the content of their site in other languages even if they have not translated it yet. So if you are selling products, for example, but still have not translated all the products on your site, they would still show in the other languages but they would be in the default language. But all the other text (minutes, widgets, header, footer, and so on) on this page would be in the correct / current language. You can read about it in our documentation here.
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

I was trying to replicate their issue in the following way.
1. I edited a default language page and disabled WPML's Translation Editor for the page I was editing.
2. I duplicated the default language page into the second language.
3. Then I edited the duplicated page and pressed the 'Translate independently' button.
4. I made a change in the text of the WPBakery element and saved the change and then updated the page.
5. On the front-end, I could see that style is gone.

Is this the correct way to replicate this issue?

If so then there is also a workaround. What you need to do is disconnect the translated page from the default language page. Then press the update button. And then reconnect the page to the default language again.

I look forward to your reply!
Thanks,
Itamar.

June 16, 2020 at 10:31 am #6382317

joonasV-2

Hi Itamar,

and thanks for the quick reply. You replicated my issue correctly and solved my problem as well by providing this workaround.

Big thanks!
/Joonas

June 16, 2020 at 10:32 am #6382321

joonasV-2

*****/*****

July 1, 2020 at 11:56 am #6495087

gregM-10

Hi, is there any chance, that you and / or wp bakery fixe this issue permanently in the next updates ? I have at least 4 websites having this issue.
Many thanks,
Greg

July 2, 2020 at 8:34 am #6501695

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Greg.

If you are not using WPML's Translation Editor please proceed with the suggested workaround.
But id this problem is happening when you do use WPML's Translation Editor to translate pages that are built with WPBakery then please open a new ticket in our support forum.

Regards,
Itamar.

August 14, 2020 at 2:04 pm #6803753

gvidoD

Hi @itamar! i have the same issue, my translated homepage is without inline styling. But weird thing is that it only effects few rows. Can you please explain in detail how to disconnect the page from translation and reconnect it back?

-- EDITED : I managed to find and this solved my issue as well. Would be nice to get this bug fixed in next updates

September 22, 2020 at 12:11 pm #7069315

alfred-ertlE

Hi,

any news on when a bugfix for this problem will be released?
I've updated all related plugins today, but the bug still exists.

The workaround mentioned by @itamar works, as long as you don't save the page again!
Otherwise it will use the CSS from the base translation page again.

September 22, 2020 at 1:18 pm #7069845

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

As this ticket marked as resolved lease open a new ticket in our support forum with the issue that you have.

Thanks,
Itamar.