This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 26, 2019 at 4:00 pm #3892039

dohunj

I am trying to:
Have an english translated contact WPform in the footer

Link to a page where the issue can be seen:
hidden link

I expected to see:

Instead, I got:

May 27, 2019 at 10:05 am #3895725

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome back 🙂

WPForm is not compatible with WPML, However, you can create a separate form and link it to the translations or use WPML > String translation to translate the form labels. Right now this is the only option we have to translate wpforms.

I hope this helps you better, Let me know if you need further assistance.

Kind regards
Raja

May 27, 2019 at 10:52 am #3896175

dohunj

Hello again 😉

ok I will give it a try,

Another issue is that all of sudden an english link from 'Chi siamo' to 'About us' is not working.

Thanks again Raja!

May 27, 2019 at 11:08 am #3896355

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I'm not sure if that is related to form or could you please explain the location where the link is not working. Make sure the link is translated properly if you have given absolute paths in a link like /about-us change it to full URL with your domain name. hidden link

Let me know if this helps

Kind regards
Raja

May 27, 2019 at 11:29 am #3896499

dohunj

I think the translation is done properly, anyway the URL is this

IT
hidden link
EN
hidden link

Thanks!

May 28, 2019 at 6:14 am #3902979

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please share temporary access to your site, The login you have shared in your previous post has been removed for privacy and security reasons as soon the ticket is marked as resolved. I have enabled private fields for you to securely share the details.

Kind regards
Raja

May 28, 2019 at 1:02 pm #3907233

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Please increase the PHP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Also please increase the PHP max input vars to 3000 your current limit is 1000, You can request your hosting provider or if you have access to Cpanel please follow the link
hidden link

Let me know if it helps

Kind regards
Raja

May 30, 2019 at 3:22 pm #3924181

dohunj

Hi Raja,

Yes, I've done increasing the PHP Memory Limit.
Then Could you manage with the links again?

Thanks!

May 31, 2019 at 10:51 am #3929947

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI,

Thanks for the information, This seems like a compatibility issue or any of your plugin is interacting with WPML. Please upload the theme used in your site to the sandbox installation so I can confirm any compatibility issue.

One Click Login:hidden link

Please note WPML is installed please activate and complete the setup, create a sample page and translate it to English add the pages to the Menu check if the issue can be reproduced there.

Please let m know once done

Kind regards
Raja

May 31, 2019 at 4:07 pm #3931925

dohunj

Thanks Raja.

I've just done installing and made a sample page.

June 3, 2019 at 5:45 am #3939427

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am unable to reproduce the issue in the sandbox site, this seems like an interaction issue that requires a detailed debugging, I would request you please share a snapshot copy of your site.

You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

Please perform some basic debugging before you proceed with creating a snapshot of your site.
- Backup your site and database
- Disable all non-WPML plugins check if the issue still persists,
- if the issue is resolved, try enabling the plugins one by one to figure out the plugin which is causing the issue.

Please let me know the results. I have enabled private fields for you to securely share the details.

Kind regards
Raja

June 12, 2019 at 4:28 pm #4006133

dohunj

Hi Raja,

It's been a while.
It is difficult to make a duplicated file through the plug-in.
Anyway, I couldn't manage to make it.
But, one suggestion for the plugin is to download all the files from my ftp.

Thus, there is around 700MB files in my computer.
Is it ok to give you like that? then which email should I send it to you?

Thanks again!

June 13, 2019 at 7:21 am #4009937

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

If you can provide a copy of your wp-content folder and database that would help as well. Please compress the copy of the wp-content folder and the database dump, upload it to g-drive or dropbox and share the link. I am enabling private fields for you to share the details,

Please note the details provided in the private fields are safe the details will be removed once the ticket is closed or resolved.

Kind regards
Raja

June 17, 2019 at 9:33 am #4033975

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have requested the second tier supporter to have a look into the issue. I will keep you posted once I receive an update from them

Kind regards
Raja

June 25, 2019 at 5:58 am #4081505

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This seems like the about-us slug (URL) got struck somewhere which is causing the issue, changing the About us page slug(URL) to something like "about" or "about-us1" one solved the issue.
I am escalating this further to check the root cause of the issue.

Kind regards
Raja