This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Riffaz 1 month, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
August 28, 2019 at 10:31 am #4473381

fredericC-9

Hello

I am trying to configure my WPML plugin. Unfortunately, I have some empty pages on my wordpress back office. Everything working fine except "translation management", "translations" and "settings" pages.

Link to a page where the issue can be seen: hidden link

I expected to see all the configuration options but instead, I got an blank page.

I allready try to :
- restore original WordPress theme
- desactivate all other plugins
- WPML is up to date

August 28, 2019 at 10:43 am #4473561

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

1. Please enable the WP Debug: https://wpml.org/documentation/support/debugging-wpml/
2. go to the page
3. what do you see now?

Regards,

August 28, 2019 at 12:10 pm #4474131

fredericC-9

Hi Riffaz,

I did what you asked me and I still see nothing on the page.

August 28, 2019 at 12:43 pm #4474283

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Do you see 'debug.log' log file inside the /wp-content/ folder?

August 28, 2019 at 12:55 pm #4474329

fredericC-9

Yes, There is some stuff inside as you can see. But It concern only my theme and a plugin and like I said before, even with another theme and without any plugin, I always have the "blank page".

August 28, 2019 at 12:56 pm #4474333

fredericC-9

The screenshot

August 28, 2019 at 1:06 pm #4474427

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details and FTP/cPanel details to check this closely.
The next reply is private.

Regards,

August 28, 2019 at 1:14 pm #4474517

fredericC-9

Thanks Riffaz,

Can you provide me your current IP address please, so you can test and work on our preproduction environment, where the problem is the same ?

If not, I will give you access to our production site.

Thanks

August 28, 2019 at 1:44 pm #4474737

fredericC-9

Thanks for your proposal, but I prefere to keep control over my website, sorry. So if you can just provide me your IP, so i can add it to our preproduction website, so you can use it for your tests.

Let me know

August 29, 2019 at 7:27 am #4478213

fredericC-9

Hi Riffaz, still waiting for yur answer. Thanks

August 29, 2019 at 8:16 am #4478591

fredericC-9

I did some test this morning and it appers that when I desactivate "WPML String Translation", all my back office blank pages works ! Any idea ?

August 29, 2019 at 8:19 am #4478603

fredericC-9

Sorry, its' "WPML Translation Management" plugin

August 29, 2019 at 8:34 am #4478705

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay.
I was thinking how to guess the cause of the issue without checking your site directly.
I am replying from Sri Lanka and I do not have a static IP.
That's why I asked the replica of your site.

its' "WPML Translation Management" plugin
- if WPML TM manager is the culprit then it should show some readable errors in error log file or in the screen when you enable the WP Debug mode.
- but it's not in your case as you say. that's why I am confused.

Could you please check the 'server log'?
You hosting support can find the cause of this if there is anything in the server log.
It will take only a minute.

If that does not help,
deactivate WPML Translation Management
delete it it.
download a new copy from https://wpml.org/account/downloads/
install and activate.
check the issue.

Let me know how it goes.
Also, let me know the communication log: hidden link

Regards,

August 29, 2019 at 9:57 am #4479573

fredericC-9

No worries Riffaz,

So, I tried again to enable debug mode and on the "settings" blank page, the log only gives me some theme errors, nothing else (see the picture).

I checked on my server logs and see nothing related to my problem.

I deleted "WPML Translation Management", downloaded and reinstalled it. Still nothing !

And, I can't access the communication log, it gives me a blank page.

August 29, 2019 at 10:08 am #4479815

fredericC-9

Also, I just discover than when my WPML TM is active (so the settings page is blank), the url for the settings page is : mywebsite/wp-admin/admin.php?page=wpml-translation-management%2Fmenu%2Fsettings

But when my WPML TM is unactive (so the settings page is worhing), the url for the settings page is : mywebsite/wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Ftranslation-options.php

I don't know if that's normal or not.