This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 53 replies, has 35 voices.

Last updated by TECS international 2 years, 6 months ago.

Assigned support staff: Amit.

Author Posts
April 20, 2017 at 7:35 am #1257687

waldemarR

I have still the issue "Key registrations for sites (new or already registered ones)".

After deactivating the plugins, delete and re-upload, it doesn't take any effect.

April 20, 2017 at 8:13 am #1257724

lionelC-5

I can't using the pluging, because

WPML Setup process block after step 2.

This is the log message

PHP Warning: in_array() expects parameter 2 to be array, string given in /var/www/html/dev.gbs.cd/wp-content/plugins/sitepress-multilingual-cms/inc/setup/wpml-installation.class.php on line 280, referer: hidden link

PHP version = 7.1
Wordpress version = 4.7.3
WPML version = 3.7

April 20, 2017 at 8:37 am #1257764

trong-phatL

I have purchased the lifetime after my subscription expired but still received this

April 20, 2017 at 8:55 am #1257785

thiesd

Yes - I did the whole cycle of deactiving, deleting and reinstalling again today, but no changes. Plugin still tells I should register, but then I get the 'no repositories message' again... See earlier screenshots.

April 20, 2017 at 10:58 am #1257918

kostasK-2

Same here, "No repositories defined" message.
I deleted plugin files and then uploaded plugin files using FTP.
Should I have deleted plugin and then reinstall through WP admin?

TIA

April 20, 2017 at 3:28 pm #1258261

jhanten

We also are having this issue where the "No repositories defined" in the Plugin section and it is asking us to register WPML. Additionally, on some of our sites WPML is generating an error message that breaks the site, but logging into the admin side temporarily fixes it. I will copy the error next time I see it to this post.

April 20, 2017 at 6:59 pm #1258462

matteoP-11

It's solved for me now: I had to delete all the WPML plugins I had on my site, download them manually from this site and upload them manually one by one.

April 21, 2017 at 7:31 am #1258708

willem-janB

After following the procedure I still get the error...
Have the feeling I was installing the same version, if there is a bug in 3.7.0 why isn't there a 3.7.1 version yet?

April 21, 2017 at 7:38 am #1258711

Amit
Supporter

If you are still getting this problem AFTER you have re-installed WPML as suggested in the first voice of this ticket please click the 'check again' button in the 'updates' page - see the image I am attaching please.

April 21, 2017 at 7:46 am #1258724

willem-janB

Nope, doesn't fix it...

April 21, 2017 at 8:14 am #1258753

Amit
Supporter

@ willem-janB please open a new ticket and mention there that I have asked you to, I will then ask you for access as I am not sure how can the file be missing and the connection to the repository failing when you have manually added the files.

Thanks!

April 21, 2017 at 9:43 am #1258837

thiesd

Solved after once again going through the whole cycle. I had to re-enter the registration key, but everything looks fine now.

Thanks.

April 21, 2017 at 10:58 am #1258910

kostasK-2

Today, everything works as expected, although I had to re-enter the registration key. Maybe the automatic update to WP 4.7.4 triggered something, who knows...

Cheers!

April 24, 2017 at 5:15 pm #1260599

vasilikiK

I have the same issue with my sites.
I will not delete and reinstall the prugin.
I prefer to wait for a new version.
Why don't you just release a minor update with the fix for this instead of risking making a mess with the unistalls and reinstalls?

April 24, 2017 at 9:47 pm #1260765

Kerry Allman

My site shows a 500 error page when WPML Multilingual CMS 3.7.0 is activated under WordPress 4.7.4. I found that if I remove 3.7.0 and install 3.6.3 instead, the site will come back up, but some of the translations are missing. I am also running: WPML Media (2.2.0), WPML String Translation (2.5.3) and WPML Translation Management (2.3). I am getting errors on the Dashboard to upgrade to 3.7 (of course) but doing that breaks the system.