Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
November 6, 2019 at 8:52 pm #4901747

Jean-Francois

I am trying to: Save my WooCommerce Product

I expected to see: Anything changed.

Instead, I got: My WooCommerce Product in the secondary language that lost all his content in the Toolset fields. Last week, I fill my content in french and in english. When I take every product and I just click on "save", I lost all my content in my Toolset fields, since the last update of WPML (4.3.3).

November 8, 2019 at 2:25 pm #4914039

Jean-Francois

Is somebody can help me with my problem? It's been 2 days since I post 🙁

November 9, 2019 at 8:10 pm #4919225

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML, Toolset, Woocommerce and WCML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

November 11, 2019 at 3:57 pm #4926491

Jean-Francois

Hi!

- My plugins are already up-to-date
- I don't have any cache
- I deactivate all the plugins, except for WPML, Toolset, WooCommerce and WCML
- I switched the theme to Twenty Nineteen

Nothing worked. So, i'm pretty sure now that it is WPML 4.3.3 or maybe WooCommerce 3.8.0, because everything happened since I updated these 2 plugins.

November 12, 2019 at 8:48 am #4929705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

November 14, 2019 at 9:31 am #4945077

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for the information provided.

I was able to log in the site correctly, however it called my eye that there are 10 pending updates. Could you update all outdated plugins and the core and double check if the issue persists? Outdated functionalities can cause conflicts in the code.

Looking forward to your message.

Regards,
Carlos

November 14, 2019 at 4:44 pm #4948753

Jean-Francois

Everything is up-to-date now!

November 15, 2019 at 10:02 am #4952461

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I applied some troubleshooting steps in the site and double check the 'translation' of the Test product and the issue seems to be gone, however after saving the translation I got a message saying that the changes were saved as a revision of the product.

I kindly ask you to double check that the issue disappeared in the Test product and to activate the debug mode in the site to reproduce the issue and check if there is some error message in the debug.log file within wp-content folder.

Regards,
Carlos

November 15, 2019 at 3:04 pm #4955095

Jean-Francois

Hi! I don't think that you saved the product with the right "save button". Look at the images I uploaded in this reply. If you save the translations in the "WPML's Translation Editor", it's working. But after, when you save your product with the traditional "save button", it clears all my translations that come from Toolset.

November 18, 2019 at 9:48 am #4963567

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

I got the same issue if un-check the 'Translation is complete' option at the bottom of the Translation Editor. In any case, I made a quick screencast where I re-save the test product and its translation using the Translation Editor and the issue seems to be solved. You can download the screencast from this link: hidden link

If the issue persists with the other products I kindly ask you to share the name or link to a product where the issue can be visible after the steps in the screencast so I can take another look.

Regards,
Carlos

November 18, 2019 at 2:01 pm #4965719

Jean-Francois

Hi! Sorry, but you didn't reproduce the problem in your screencast. I sended you images with the procedure. When you're in the Translation Editor, it's true that when you save it, it's working. But, if I decide to change the content of the primary language and I save my page, it makes my custom fields all empty.

Look at my screencast, you will understand what i'm saying :
hidden link

November 19, 2019 at 9:22 pm #4975899

Jean-Francois

Is there any other way you can help me?

I tried to setup Cloudways and it says "Unable to access wpconfig file. Please check if WordPress is installed on the destination address. Also, check if you have permission to access the folder".

I know the server address is good, but I get an error on this field. I can give you access to the FTP directly, we have daily backups.

November 20, 2019 at 9:07 am #4977841

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you for your feedback.

In this case I would like to ask your authorization to create and download a copy of the site for testing purposes.

Looking forward to your message.
Regards,
Carlos

November 20, 2019 at 2:44 pm #4981405

Jean-Francois

Yes, you have my authorization to create and download a copy of the site for testing purposes.

November 20, 2019 at 8:08 pm #4983891

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for your authorization.

We released a new version of WPML and I kindly ask you to update to this new version and double check if the issue persists.

If the issue persists I will create the copy of the site and escalate this ticket to our 2nd tier of support. I already installed the Duplicator plugin to create the copy.

Note: Please update all the outdated plugins, just to rule it out as a possible cause.

Regards,
Carlos