This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Bruno Kos 5 months ago.

Assigned support staff: Bruno Kos.

Author Posts
May 19, 2019 at 4:47 pm #3842109

Mr. Ghost

I am trying to:
Translate a page. Using the core multilingual CMS plugin only. We do not want to use anything else.

Link to a page where the issue can be seen:
Can not share since you have this ticket system open for the public and I do not want to share. Make this whole thread private and I can share more information and print screens and videos.

But I will not share anything until you made this post private. No, I will not be OK that you delete it later on. Then it's still public until you delete. Make it private from now and I can share and then we can delete the post. Please respect and understand customers privacy.

I expected to see:
Page 200 and working. Extremely annoying this is the 50th bug I experience since we started to use WPML. Homepage works but no other pages work to create just end up as 404 in the secondary language. How come? What is causing this?

Instead, I got:
Broken page and a 404

May 20, 2019 at 7:35 am #3844247

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Make this whole thread private and I can share more information and print screens and videos.

That is not possible at all with our ticketing system, but our Chat feature is private and whatever you enter there is private. Can you try there?

Regards,
Bruno Kos

May 20, 2019 at 4:25 pm #3848847

Mr. Ghost

If I try to start a chat I will just start multiple and duplicate tickets since you force a ticket once the 5min threshold passed.

I will soon stop using WPML, no privacy in ticket and just bugs after bugs. You know how much bugs and issues we have faced with WPML it's soon making me go crazy. As soon as I think everything works something else pops up and it is always connected to WPML.

And above could I at least have seen a support response? Not too much to ask for, even if I want my message to be hidden I would expect your response to be moving the needle but no.

I've cleared and check everything in wpml cleared cache regenerate and all still 404 when I try to create a translation of a page.

May 21, 2019 at 10:53 am #3854525

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The chat would get closed if all chat supporters are busy at the moment and can't take another one in that time period.

Homepage works but no other pages work to create just end up as 404 in the secondary language. How come? What is causing this?

I can't even start guessing because there could be various reasons behind this, server, non-server related, etc. I've activated private reply and you can put any information inside you think I could use - Duplicator package would be most useful for me to debug this locally and possibly escalate further to our 2nd tier.

Regards,
Bruno Kos

May 22, 2019 at 6:07 am #3861059

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Then we tried once again and now it works on a brand new application.

Does it mean that you don't need more assistance on this, or?

Regards,
Bruno Kos

May 22, 2019 at 8:14 pm #3868949
Mr. Ghost

Yes since now we have another issue:

WPML media translation page shows images that do not show in the media library for a language.
WPML language on the list view of media library does not work.

Can not delete images that don't exist. What is wrong with WPML guys 🙁

Just broken once again, this is a never-ending story with WPML. Can you imagine and understand my frustration? Developed sites in 4years and never ever experienced a plugin cause so much hassle that WPML has done in 1 month for me.

May 22, 2019 at 9:12 pm #3869317
Mr. Ghost

Can you please explain to me why WPML change the main language for images that are uploaded from e.g US and change it the main language of it when I check /admin.php?page=wpml-media

And why it's completely different lists of images in media library list and grid view. Something is really wrong with WPML lately.

And why the translated images are in same url folder /wp-content/uploads/ and not /language/ folder? Just rename file names does just translate an image not give me options to do how I
consider is the right way. Separate them correctly and in a good way according to me by separate them in folders and languages exactly as the frontend url of pages.

Why above? Since you only give me options to translate the file name and not the alt texts. Another thing I do not understand. And I fetch images with ACF and array meaning fetching alt text from media library this has to work multilingual. I will not make alt texts static and fetch them on page level.

And when I'm on list view and switch language from man language it redirects back to the main language....

New threads created by Bruno Kos and linked to this one are listed below:

https://wpml.org/forums/topic/split-wpml-404-page-when-adding-translation/

May 23, 2019 at 7:34 am #3872093

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Closing this topic because I created new tickets for other issues.

Regards,
Bruno Kos