Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Itamar 4 years, 6 months ago.

Assigned support staff: Itamar.

Author Posts
January 1, 2017 at 3:31 pm #1171992

david

כל העמודים נעלמו לאחר שינוי דומיין האתר
מקבל 404
ביצעתי כבר מספר דברים שהיו אמורים לעזור אך ללא הצלחה
אני בדיוק באמצע העברת האתר לדומיין שלו וזה קרה..
אשמח לעזרה בהקדם האפשרי
תודה

January 1, 2017 at 3:36 pm #1171994

david

All pages have disappeared after the website domain change
Receive 404

January 1, 2017 at 4:18 pm #1172001

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, David.

Thank you for contacting the WPML support forum.
I'll continue here in English since you have posted your ticket on the English forum.

Currently when I check your website I can see the pages in Hebrew and English?
Have you solved the problem already?
If not can you elaborate on the issue, please?
Are you sure that this problem is related to WPML?
Do you get the 404 only on translated pages or on all pages?

Thanks,
Itamar.

January 1, 2017 at 4:35 pm #1172005

david

What you see is the existing site
To see the new site should redirect the domain to ip

185.56.72.225 gonogo.co.il
185.56.72.225 hidden link

The problem all pages
And related to wpml
Something must be chenge in the database

January 1, 2017 at 4:59 pm #1172008

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

That is what I see. for the home page of your site.
Please, see attached screenshots.
If I check this website.
hidden link
It says the IP of this website is different then what you are specifying above.
I think that you should check your DNS and server settings.
I'm sorry, but I still can't see an issue that is related to WPML.

gonogo-he.jpg
gonogo-en.jpg
January 1, 2017 at 5:05 pm #1172014

david

!!
To see the new site should redirect Local in hosts file on your computer the domain to ip

185.56.72.225 gonogo.co.il
185.56.72.225 hidden link

January 1, 2017 at 5:39 pm #1172022

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

OK, now I understand.
Thanks for explaining.

I can now see the problem on your site.
I see this when I try your new site. Please see attached screenshot.
From the debug information that you have attached I can see that Hebrew is the default language of your site.
Problems that result from WPML usually related to the translations of the site.
In other words, for the English language on your site.
If the issue is related to WPML then deactivating it should solve the 404 problem.
You would be able to see your site at least in Hebrew.
Can you, please deactivate WPML and see if it makes any difference?

Thanks,
Itamar.

gonogo-new.jpg
January 1, 2017 at 5:49 pm #1172024

david

Obviously I tried it and it all works
The problem in wpml
"wpml 404 pages not found after domain change"

Also tried this and did not help
https://wpml.org/forums/topic/issue-after-transferring-site-to-new-domain/

?????

January 1, 2017 at 6:20 pm #1172030

david

I try something else
So in the meantime do not need more help
Thanks

January 1, 2017 at 7:26 pm #1172037

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Ok.
I'll wait for your reply in case that you'll need more help.

The topic ‘[Closed] wpml 404 pages not found after domain change’ is closed to new replies.