Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm translating my website and I set translation preferences almost everywhere to "Copy once" since I want to only change same content (the content should be copied and then I can change what I want, right?). When I'm about to publish 2nd language page I get this big notification about fields that will be copied. I click "Publish" and not everything is copied.

Solution: Make sure that the Group and Repeater types of fields are set to Copy while all the other fields need to be set to Copy, Copy once or Translate, based on your needs. Also, as explained here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-translation-preferences-acf-fields the fields set to copy once will not appear on the Translation Editor screen.

Relevant Documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Radu 7 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
March 31, 2020 at 4:45 pm #5806575

filipC-5

Hi there,

1. I'm translating my website and I set translation preferences almost everywhere to "Copy once" since I want to only change same content (the content should be copied and then I can change what I want, right?). When I'm about to publish 2nd language page I get this big notification about fields that will be copied. I click "Publish" and not everything is copied (actually less that half of the content) - can you please help me with that?

Also, I won't be very specific, but sometimes when I translate the website something weird and funky is going on - sometimes some content from my default language is missing, sometimes the content "moves" to another field. Any idea what is going on?

2. It's a separate issue, so let me know if I should create a separate ticket for it, but maybe there's a quick and easy fix for it - I can't translate my media files, the "Save" button is disabled. Why?

April 1, 2020 at 11:25 am #5812339

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Filip,

Thank you for reaching out to the WPML support!

You are right about the copy once setting for the custom fields. The values of the fields should be copied to the translation. Is there any chance that you could give me access to the dashboard area and send me the link to a page where you are using custom fields, please?

I just want to see which fields are copied and find out why is not everything working as expected.

Regarding the second question, we can take care of it after we sort things out about the custom fields. However, I encourage you to open a separate ticket for you because one of my colleagues can take it and check it out. This way you'll get everything sorted out faster.

Thanks,
Radu

April 3, 2020 at 7:30 pm #5835339

filipC-5

Hi Radu,

right now I have WMPL on localhost only. All get back to you in a couple of days, when I move it live.

About the second question - your colleagues will probably need to take a look under the hood as well, right? So I might as well do it all together, when the WMPL will be live.

Cheers,
Filip

April 5, 2020 at 8:41 pm #5842947

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Filip,

No worries. Just give me a message back once you get your website online so I can have a look at this issue. The next reply is set to be private so you can safely send me the credentials.

You're right about the media issue. It might require having a look at your website so it's a good idea to open a new ticket when your website will be online.

Thanks,
Radu

April 12, 2020 at 8:35 pm #5892883

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Filip,

I had a look at your website and I could see that this is a page that uses custom fields and it's not translated: hidden link

Now, can you tell me which fields would you like to be copied and which ones you'd like to translate, please? Once you tell me this, I'll check the settings of the custom fields to make sure that they were set correctly.

Also, you can have a look at our documentation about using WPML and Advanced Custom Fields together:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Thanks,
Radu

April 13, 2020 at 6:39 am #5894485

filipC-5

Hey Radu,

yeah, still plenty of pages to translate. But you chose a good one for tests. If you could set the setting for me I'd be grateful. Let me know when I can hit the "add translation" plus.

Cheers,
Filip

April 16, 2020 at 7:44 am #5919523

filipC-5

Hey Radu,

did you manage to do that?

Cheers,
Filip

April 16, 2020 at 11:19 am #5921827

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Filip,

Sorry for this delayed response. A copied all the settings of the Projekty group field from your website, run some test on my website, then checked again your website.

I also created a translation for the Realizacje page (hidden link) and everything worked fine.

If you check the translation here:
hidden link

you can see that all the fields are set fine. Can you have a look too and tell me if there's any element that's not copied well so I can check it, please?

Thanks,
Radu

April 16, 2020 at 11:31 am #5921975

filipC-5

Yep, everything seems fine, thank you! Would you be so kind and give me short step by step guide what exactly did you do?

April 16, 2020 at 11:36 am #5921993

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Filip,

I honestly didn't do any major change. I just checked all the custom fields and make sure that the Group and Repeater fields are set to copy, while all the other fields were set to copy once or translate.

These are the settings that I used on my testing website and that I copied on the custom fields from your website too.

Thanks,
Radu