This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After an update I receive the message that the update is not complete. Solution: Try these steps: - Remove the main WPML plugin (WPML Multilingual CMS) - Do a first-time install of the main plugin: https://wpml.org/faq/install-wpml/#first-install - Go to Dashboard -> Updates - Press the "Check Again" button - Update the other plugins Relevant Documentation: https://wpml.org/faq/install-wpml/#first-install

29% of people find this useful.

This topic contains 23 replies, has 8 voices.

Last updated by Vincenzo 7 months, 1 week ago.

Assigned support staff: Vincenzo.

Author Posts
February 7, 2019 at 10:38 am #3169625

martaM-13

While updating WPML core and addons, the two addons String Translation and Translation Managemnt won't upgrade: I get the message "Aggiornamento fallito.Il download non è andato a buon fine. Not Found"

February 8, 2019 at 10:48 am #3174688

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!
Usually, this is a temporary issue.

Try these steps:

- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button
- Try to update the plugins

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not fix the issue you can manually update the plugins.
❌ Before proceeding please make a full website backup! ❌
- Download the latest version of WPML from https://wpml.org/account/downloads/
- Disable WPML Multilingual CMS
- Delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded WPML plugin from Plugins -> Add New -> Upload Plugin
- Activate WPML

Please let me know if this solves the issue or if you need further details.

Thank you

February 8, 2019 at 3:15 pm #3175906

martaM-13

Hello Vincenzo.
Thank you for your reply.
The only thing that seemed to work is the third advice of yours: deleting and manually reinstalling WPML Multilingual CMS. Now all the addons appear as if they were updated (there's no message about needed updating) but the number of the version is not the last one and also in the upper part of the page I still have the message "L'aggiornamento non è stato completato", with the list of the two addons to update...this is kind of weird. Should I manually upload the last versions as I did for the core or should I leave it this way?

February 8, 2019 at 3:20 pm #3175917

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

you can manually remove the outdated versions of the plugins and upload the new versions.
If you prefer, you can send me the credentials and I will ask one of our developers, that is investigating this issue, to take a look at the site before the updates.

Just let me know. I am enabling a private reply, just in case.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
hidden link

Thank you

February 9, 2019 at 10:10 am #3178190

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi, thank you for your credentials.

Our developer found the cause of the upgrade issue and now it should be fixed.

These are the steps used to fix the issue on your staging site:

  • Go to Dashboard -> Updates
  • Press the "Check Again" button
  • Update the plugins

Please try these steps on your production site and let me know if the issue is fixed.

Thank you

February 12, 2019 at 8:24 am #3187065

martaM-13

I'm not sure what you refer to as "staging site", did you create one in order to try the fix? On the website I gave you the credentials for there was no need to do anything, the two plugins were already updated. On the other website I did the same procedure as the first one (deleting and reinstalling Multilingual CMS) and now the two plugins are not to update even though they don't have the correct version number. Anyway I imagine the issue is solved here to. Thanks!

February 12, 2019 at 11:25 am #3188092

martaM-13

Sorry about that, but getting back into the second website (hidden link) I noticed that, again, the two plugins are to be updated. And trying to do so by the procedure indicated by Vincenzo doesn't work. Maybe you need to get into this website also in order to fix it?
Or you can tell me how to do it? Let me know, thanks.

February 12, 2019 at 11:58 am #3188275

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
hidden link

❌ Please make a full website backup! ❌

Thank you

February 12, 2019 at 12:22 pm #3188429

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

I updated the plugins on the website.
In this case, I needed to disable and remove our two plugins and to upload the new versions.
The backend was a little slow, perhaps for the Query Monitor plugin, so maybe the "Check Again" button was not working correctly.

Please let me know if this solves the issue or if you need further details.

Thank you

February 14, 2019 at 8:12 am #3198050

martaM-13

Dear Vincenzo,
thanks for your intervention. Unfortunately it seems the issue is still not resolved. I just got in and found new updates for both addons and also for WPML multilingual CMS. I tried to update from the plugin page and encountered new problems; I then deactivated Query Monitor and tried updating from the Updates page by clicking on the "check again" button and then on the "update plugins". You can see the result in the attached image...

February 14, 2019 at 8:19 am #3198071

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

please try these steps:
- Remove the main WPML plugin (WPML Multilingual CMS)
- Do a first-time install of the main plugin: https://wpml.org/faq/install-wpml/#first-install
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Update the other plugins

Please let me know if this solves the issue or if you need further details.

Thank you

February 14, 2019 at 8:41 am #3198180

martaM-13

Ok, everything's fine now. I hope it will not happen the same with next updates but in that case I guess I will have to manually update. Thanks for your help.

February 20, 2019 at 4:45 pm #3223059

chielv-2

Hello Sir

i have one issue...how to set other domain url format in wpml with domain also can you suggest me what setting we need in hosting please need very urgent to set
this is my website hidden link i want to set hidden link in English Flag

February 21, 2019 at 8:24 am #3225635

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello @chielv-2
this ticket is closed.

May I ask you to open a new ticket?

You can do it from here: https://wpml.org/forums/forum/english-support/

In the meantime, please take a look at this article:
- https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Thank you

February 22, 2019 at 4:59 am #3230947

rosa-mariaC-2

Hi Vincenzo,
I also tried to update the plugins and got the above errors. I tried your advice to do the following
Go to Dashboard -> Updates
- Press the "Check Again" button
- Update the other plugins
and it still persist.