This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Carlos Rojas 11 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
February 12, 2018 at 7:10 pm #1515322

jeffryD

Hi, I don't know what made it break but I had to disable wpml all import to be able to import my users with wp all import in to my website.

Since it was an easy fix, I'm not making it a support issue.
But I think it is worth mentioning after having wasted half a day troubleshooting and wondering what I was doing wrong.

Cheers.

February 14, 2018 at 2:13 pm #1517744

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Can you please elaborate a little more so I can have a better understading? Also, could you provide the steps to reproduce the issue?

Kind regards,
Carlos

February 14, 2018 at 5:24 pm #1518052

jeffryD

Well I made a woocommerce website using wpml (your colleague, Lauren helped me with it already so you should have access to all data concerning the server etc I'm working with)
And I used wpml all import to upload a bunch of products, this was a pretty painless process.

now I needed to add a bunch of users.
I received a client list generated out of the bookkeeping software. In it some data like, names, email, client number...
In an excel file, I altered a couple of tables to be better compatible with wordpress
tried to import and I got a message the server wouldn't import the users.

Tried it after I converted the list in to a csv, no success. server told me it wouldn't import.
I did a boat load of other table layouts of the clients, wondered if it was because the passwords in the bookkeeping program wasn't strong enough so I left out the passwords and maybe needed strong passwords so I had it generate it's own passwords.
Still no glory server wouldn't accept the import.

only after disabling "wpml all import" only leaving "wp all import" would the list be imported, including the passwords.

February 14, 2018 at 6:08 pm #1518115

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Thank you very much for this information.

1.- I will consult my my colleagues regarding this issue and I will get back to you as soon as I have an answer.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you for your patience.
Kind regards,
Carlos

February 15, 2018 at 1:31 pm #1519005

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I have consulted my colleagues and if the content of the users is not translated then there is no need to have the WPML All Import active while importing users. However, this should be solved in the latest version of the plugins.

Could you double check you are using the latest version of the plugin?

In case all plugins are up to date, then I kindly ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Looking forward to your answer.
Kind regards,
Carlos

February 15, 2018 at 1:53 pm #1519046

jeffryD

Hi Carlos as stated initially.
I made this post to notify you (the developers) of a bug I encountered while importing users and how I managed to fix it by disabling wpml all import.

To my knowledge I'm running the latest version of all wpml plugins, so it isn't fixed in the latest version as I wasn't able to import users with it enabled.

I hope the debugging info will help resolve the issue for other users

February 15, 2018 at 4:21 pm #1519404

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Thank you very much for let us know this issue. I'm going to contact our specialists with this information and they will look into this to try to find the cause of the issue and the correspondent solution.

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Kind regards,
Carlos

October 27, 2018 at 12:06 pm #2855090

laureneD

Hi guys, i've also just walked into this problem. I need the WPML All Import plugin for all the other imports though. In the latest version 2.0.8 i still can't import users with the plugin activated. Can you please update me on this situation?

I will also create a seperate support ticket.

Thanks!

October 29, 2018 at 12:08 pm #2857864

laureneD

There is a bug in the version of the rapid-addon.php file within the WPML add-on for WP All Import. I believe they will fix it in their next release, but in the meantime, you can update the following two lines in /wp-content/plugins/wpml-all-import/includes/rapid-addon.php from:

$data[$option_name] = XmlImportParser::factory($xml, $cxpath, $import->options[$this->slug]['xpaths'][$option_name], $file)->parse($records);
$tmp_files[] = $file;
}
} else {
$data[$option_name] = XmlImportParser::factory($xml, $cxpath, $import->options[$this->slug][$option_name], $file)->parse();

to:

$data[$option_name] = XmlImportParser::factory($xml, $cxpath, (string) $import->options[$this->slug]['xpaths'][$option_name], $file)->parse($records);
$tmp_files[] = $file;
}
} else {
$data[$option_name] = XmlImportParser::factory($xml, $cxpath, (string) $import->options[$this->slug][$option_name], $file)->parse();

You will find this code on lines 874 - 878.

October 29, 2018 at 2:19 pm #2858351

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

As the original ticket is closed I kindly ask you to open a new ticket and describe this issue. This way you will get a better support service experience and it will help future clients to find an answer to a similar issue in the future.

Thank you very much for your understanding!
Best regards,
Carlos