We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was importing posts in two languages, the posts were not linked as translations. Solution: The user was not using the connector in the "Unique Identifier" field. As you may see in our documentation article, the yellow section before the video "Please note when setting the “Unique Identifier” (@3:34) (@4:57) choose “Connector” instead of “Title”." Relevant Documentation: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

This topic contains 8 replies, has 3 voices.

Last updated by Christian 1 month ago.

Assigned support staff: Jamal.

Author Posts
October 10, 2019 at 8:58 am #4728533

Christian

I am trying to: Following all instructions and using fully updated versions of WP/WPML/WP All Import Pro, I am trying to import original and translated CSV files.

Link to a page where the issue can be seen: site is in development

I expected to see: link between all translations indicated by pencil

Instead, I got: translations are not connected, even though i am setting the original during import as per instruction

October 10, 2019 at 4:21 pm #4732773

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Could you please confirm that you have followed all steps of this guide? https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Please make sure to select the correct language, link to the original import and that the "unique identifier" is the same from the original import.

If the issue persist, please let us know.

It's also possible to connect each post manually:
- Go to the edit screen of the page (secondary language)
- On the right sidebar, there is a "This is a translation of" item, select the original post on the list
- Save

All the best,
Diego

October 10, 2019 at 4:37 pm #4733033

Christian

Hi Diego,

thanks fo the quick reply. I did indeed follow the guide, watched the video several times 😉

I am going to have 2500 posts for 5 languages. A manual edit will not be possible.

Best
Chris

October 10, 2019 at 5:20 pm #4733165

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Chris,

Please record a video of your import to at least the primary language and one secondary language. I often use loom or screencastify to record a screencast.
The private box is activated to let you share the video link safely and protect your privacy.

Best regards,
Jamal

October 10, 2019 at 5:35 pm #4733261

Christian

Ok, will record a video and share it via google drive.

Do you mean with "private box" that this chat is now private? Or where do I find the private box?

Regards
Chris

October 10, 2019 at 7:43 pm #4733847

Christian

... i also uploaded the CSVs to the same folder

October 11, 2019 at 9:44 am #4736905

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I believe that the issue is caused by using "title" as a Unique Identifier instead of the Connector.
As you may say in our documentation article, the yellow section before the video "Please note when setting the “Unique Identifier” (@3:34) (@4:57) choose “Connector” instead of “Title”."
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

I created a new website and configured it with German and English, then I imported both files and everything went ok. See my screencast
hidden link

Check the website with this one-click login link
hidden link

Best regards,
Jamal

October 11, 2019 at 10:07 am #4737041

Christian

Dear Jamal,

I am endlessly sorry for not getting it right in the first place and wasting your valuable time with this! I appear to have it working now too.

Even thought the yellow message is obvious, I still recommend to redo the video. This importing topic is a very finicky task and the documentation should be very sharp. I am afraid it is not really.

I thank you and all at WPML for the great plugin!

Regards
Chris

October 11, 2019 at 10:08 am #4737043

Christian

My issue is resolved now. Thank you!