We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 4 voices.

Last updated by George Botsev 4 years ago.

Assigned support staff: George Botsev.

Author Posts
October 11, 2015 at 3:19 am #722158

pavelM-3

I am trying to: Upload translations for existing properties with help of wp-all-import and wpml-all-import addon. I have 300 properties in English, all the properties have unique key property_id. Properties were uploaded in a few times.
When I use wp-import-all, in the "WPML Add-On" section I'm choose "Content Language" as "Russian", but at the "Automatic Record Matching to Translate > Records matching logic" section there is "Import data in main language (English)" radio is selected by default. This is made me to completely don't understand the logic. I want to add Russian translates to existing properties, I've choose Content Language as Russian, but the data will be imported in English?
And yes, Taxonomies, Cities, Types, Statuses and all other data were imported in English, without translation. Why?

I'm able to select the "Define parent import" radio and set the "Unique Key" field, but I don't have parent import (1. It was removed. 2. Data was been imported in several imports).

What I expect: I expect that addon will find all properties in English matching the Unique Key property_id and will add Russian translations. But all I get is newly created untranslated properties. Translations are not linked with original using unique key (property_id).

How can I import translations to existing properties if I don't have previous imports in English?

October 12, 2015 at 2:47 pm #722963

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

That is a good point, why that switch to English...

I think this best way to look into this would be a duplicate/clone of your website.
This way we could really look deeper into it and run tests without interfering in your live site.
Could you provide such a clone for us?

# Steps for creating and sending such duplicate, we recommend:
1) Install plugin "Duplicator" - http://wordpress.org/plugins/duplicator/

2) After you've installed the "Duplicator" plugin, please go to hidden link and create a "Package".
The package is a "Installer" and a "Archive" - we need both files.

3) Then send this package to us via hidden link - my email is andreas.n@onthegosystems.com

Thanks!

October 14, 2015 at 5:53 am #724304

pavelM-3

Hello Andreas,

Files are sent.

WP-All-Import template is "Export with amenities". Files with the Russian properties: export_ru.csv and export_ru_part.csv (18 properties for test import).

I tried a lot of different options in ./themes/realhomes-new/wpml-config.xml - at @taxonomies/@taxonomy/@translate : 0, 1 and 2 - sometimes a got translated 3 of 4 taxonomies, but when I remove all exported items and tried to repeat steps, I got items untranslated again. I got confused.

For today I spent 10 days trying to translate properties but get no luck. Please help, this takes to long time for such simple operation.

Thank you.

October 14, 2015 at 9:44 am #724544

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Thanks for the files!
I think I need to escalate this to our 2nd level support.

To make it easier for the colleagues - the expected steps are these I would say:
1) Go to "All Import > New Import"
2) Choose "Upload a file"
3) Choose "export_ru_part.csv"
4) Choose then "Import data from this file into... > Existing Items > Properties"
5) Press "Continue Step 2" and "Continue Step 3"
6) Scroll all the way down and choose "Export with amenities" as template
7) Press "Continue step 4"
8) Press "Confirm and Run Import" and wait
=> Expected: Russian translations were added to *existing* English properties

# Are the steps correct?

October 14, 2015 at 1:27 pm #724791

pavelM-3

When I tried to do that on dev server, I got strange message "Are you sure to do that?" without any button to answer. I think that was WP-Import-All bug.
But since advice was from developer I performed this actions on the production server. As a natural result, I lost the English descriptions, titles and other data, all imported properties has been rewritten with Russian versions and the language of those properties has been changed to Russian. So no more original properties with same property_id in English. That's sad.

I gonna try to restore original properties. Anyway, I hope my experience will make it easier for your colleagues to sort this out.

So the short answer is: no, it's not working.

October 14, 2015 at 5:00 pm #725042

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'm Bruno and I'm handling this issue now.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 15, 2015 at 12:46 am #725234

pavelM-3

Requested credentials are sent.

Found new problem. I can't figure out whether the problem appeared as a result of one of imports, or as a result of the latest plugin updates. As you can see on the attached screenshot, all taxonomies from all languages now shown in one place, whatever language you choose. That's killing me.

October 15, 2015 at 9:16 pm #726236

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry, I got confused. The files "export_ru_part.csv" should be available within the WordPress?

I looked in the FTP, but did not find these files. You sent them to my colleague, Andreas?

Thank you.

October 15, 2015 at 9:44 pm #726254

pavelM-3

Sorry, I just uploaded the files to the "import-csv" directory.

October 16, 2015 at 10:50 pm #727128

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I saw the problem you are reporting.

I will assign it to the 2nd tier support and soon we'll get in touch.

These posts that were created in Russian, I can exclude so that the 2nd tier support can follow the same steps?

Thank you.

October 17, 2015 at 7:25 am #727167

pavelM-3

Sure, please feel free to change anything you need on the development server.

October 20, 2015 at 3:46 pm #729177

pavelM-3

Are there any results?
Our website not working for almost three weeks.
Is there any chance that the plugin will work?

October 26, 2015 at 1:59 pm #732684

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, I am George from second tier support.
I am trying to debug this issue that you have for quite some time now.
I see that in your file with Russian properties, you don't have translation for the categories and I can also see that you cannot match the files for something similar in order for the translations to be linked.
Do you have a field that can match the content from one language to the other?

You might want to re-create the export files with the proper information.
Also please visit our tutorial here: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

November 3, 2015 at 10:49 am #738184

pavelM-3

Finally I found the working scenario. After hundreds of attempts, after going through the pain and humiliation.

0. Delete all created imports (Delete associated posts as well), delete all previously imported properties, empty trash
1. All Import > New Import
2. Click "Upload a file"
* select file import.csv *
3. New Items > Properties
4. Click "Continue to Step 2"
5. Click "Continue to Step 3"
6. Scroll down, select template "Export with amenities"
* WPML Add-On > Content Language > English ( default ) *
* Automatic Record Matching to Translate > Records matching logic > Import data in main language (English) *
7. Click "Continue to Step 4"
* Unique Identifier = {property_id[1]} *
8. Click Continue
* WP All Import will import the file wp-co****/import.csv, which is 1.84M *
* WP All Import will process 347 rows in your file *
* Your unique key is {property_id[1]} *
9. Click "Confirm and Run Import"
... Import in Progress ...
* Import Complete! *
10. Click Properties and we see that the Price and Property ID are undefined
11. Click to edit any propery and see that the "Additional Detais" is empty

!Trick!

12. Click "All Import" > "Manage Imports"
13. Find latest import "import.csv", click "Import Settings"
14. In the "Record Matching" section we can see that the radio button "Choose which data to update" is selected and only 3 checkboxes are checked (Title, Slug, Content)
15. Select radio "Update all data" instead of "Choose which data to update"
16. Click "Save Import ..."
17. Click "Run Import", "Confirm & Run Import"
... Import in Progress ...
* Import Complete! *
18. Click Properties and we see that the Price and Property ID are updated
19. Click to edit any propery and see that the "Additional Detais" is updated

Almost done!

20. All Import > New Import
21. Upload a file
* select file import_ru.csv *
22. New Items > Properties
23. Click "Continue to Step 2"
24. Click "Continue to Step 3"
25. Scroll donw, select template "Export with amenities RU"
* WPML Add-On > Content Language > Russian *
* Automatic Record Matching to Translate > Define parent import > [ ID: 56 ] import.csv *
* Unique Key: {property_id[1]} *
26. Click "Continue to Step 4"
* Unique Identifier = {property_id[1]} *
27. Click Continue
* WP All Import will import the file wp-con****/import_ru.csv, which is 2.32M *
* WP All Import will process 347 rows in your file *
* Your unique key is {property_id[1]} *
28. Click "Confirm and Run Import"
* Import Complete! *
29. Click Properties > Russian and we see that the City, Type and Status are not translated
30. Click Edit ANY(!) property
31. See that Property Features (same as City, Type and Status) are empty
32. Scroll down to the "Multilingual Content Setup" and see that all radio buttons are unchecked
33. Click "Apply"
34. Click Properties > Russian and we see that the City, Type and Status have been translated

WOW!

This is the only way for me to import translations.
Is this the correct way to import?

And one more thing: In created translations "Property" > "Gallery Images" > "Gallery Type You Want to Use" is unchecked, so all thumbnails are on the right. But in the "Import Settings" for the Russian import, in the plugin "RealHomes Add-On" > "Advanced Settings" > "Gallery Type" > "Thumbnails on bottom" is checked. But ignored.

November 3, 2015 at 12:40 pm #738317

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I think that the issue may be in the part were you select a template for your import - "Export with amenities" is a template that defines what to import and where/how.
However the other steps here seems fine to me. I am not sure what exactly is needed to be done in "Multilingual Content Setup" but if you have custom fields - then you need to adjust them accordingly. Please do mind that the free version of WP All Import does not provide the functionality to import custom fields and all of the fields that you imported are because of your theme provided add-on for WP All Import so I am not entirely sure what is going on there, and the issue that you have currently may be direct result from that.
Let me know if there is anything that I can help you with.

The topic ‘[Closed] WPML-All-Import’ is closed to new replies.