This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Dennis 3 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
July 7, 2019 at 8:10 pm #4158147

marthijnd

WPML doesn't find all the strings from the plugin (GDPR Cookie Consent) what needs to be translated. For example necessary and non-necessary, but there are some more.

How can I translate this, I bought WPML because it was compatible with this plugin?

Kind regards

July 8, 2019 at 2:04 am #4158345

Dennis

Hi,

Welcome to WPML Support forum.

Could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Kind regards,
Dennis

July 8, 2019 at 8:03 am #4159787

marthijnd

Added debug text

July 8, 2019 at 9:12 am #4160477

Dennis

Hi,

Thank you for providing us with the debug information.

Please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then:

-go to WPML > Theme and plugins localization
-go to WPML > Theme and plugins localization. Be sure that 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' is selected.
-under Strings in the plugins section, select 'GDPR Cookie Consent' plugin.
-click 'Scan selected plugins for strings'
-go to WPML > String Translation
-try to search for the strings again in WPML > String Translation and translate them completely.

Does it help? Please let me know.

Kind regards,
Dennis

July 8, 2019 at 11:42 am #4162029

marthijnd

I added the rule to the wp-config.php and when When I set the max vars to 5000 I also saw an option there to increase the memory, so I have done that as well. See attached print.

Not sure if this was necessary? Or that I didn't have to change the wp-config.php and only the setting here was ok. So for now I have both.

But nothing improved, still missing the string Necessary and Non-necessary. Even when I search in all tables I can't find it.

Kind regards

July 8, 2019 at 11:44 am #4162033

marthijnd

Attachment

July 9, 2019 at 3:42 am #4167251

Dennis

Hi,

Thank your for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

July 9, 2019 at 9:20 am #4168931

Dennis

Hi,

Thank you for providing us the access details.

This seems to a compatibility issue. I was able able to reproduce the issue on a clean install. I will consult our specialist about this issue for further investigation. I will update you here as soon as I got some feedback from them.

Kind regards,
Dennis

July 9, 2019 at 2:01 pm #4171563

marthijnd

Okay thanks. Will wait for your reply.

Did I need to change the wp-admin.php file with the 256M memory line by the way? Or if I only change it on the (PHP) printscreen from my previous message it is enough?

Then I know it for future sites.

Kind regards.

July 10, 2019 at 6:49 am #4176369

Dennis

Hi,

Thank you for your reply.

No need to add the code on your wp-config file.

The issue has been escalated to our Themes & Plugins Compatibility Team. They will investigate the issue and will try to contact the plugin author. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

Kind regards,
Dennis

July 11, 2019 at 3:34 am #4185857

Dennis

Hi,

Our compatibility team will try to contact the plugin author. Meanwhile, please follow these workaround steps:

#1 In wp-content/plugins/cookie-law-info/public/class-cookie-law-info-public.php:55 change from:

public $cookie_categories = array(
        'necessary',
        'non-necessary'
);

TO:

public $cookie_categories;

#2 And in wp-content/plugins/cookie-law-info/public/class-cookie-law-info-public.php:69 add:

add_action('init', function (){
            $this->cookie_categories = array(
                __('necessary','cookie-law-info'),
                __('non-necessary','cookie-law-info')
            );
});

You're code should look like the attached image.

#3 Re-scan plugin strings again and translate them accordingly.

Kind regards,
Dennis