Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by RCPlanet 9 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 7, 2019 at 11:56 am #4706839

RCPlanet

Good day,

Makecommerce plugin support said that problem is with WPML.

In woocommerce settings -> payments
when i installing Makecommerce payment and save changes its disable by himself.

October 7, 2019 at 6:01 pm #4709939

RCPlanet

As i found, problem is with WPML String Translation, when i disable it, Makecommerce work fine.

October 8, 2019 at 12:22 pm #4715095

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Makecommerce is not listed at our compatibility plugins page: https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=Makecommerce&wpv_filter_submit=Search

This seems to be a new compatibility issue. In these cases, these are the procedures:
- Install the plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the plugin to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

All the best,
Diego

October 8, 2019 at 12:34 pm #4715177

RCPlanet

Good day,

Thank you! I made same settings on your test website, and there it works fine. But on my website it works when i disable WPML String Translation, as i tested by disabling all plugins.

To check.
You need to go - Woocommerce -> Settings -> Payments -> MakeCommerce – Pay with bank-links or credit card ( Set up or Manage if on )

And i need to make mark on ( Enable/Disable - Enable MakeCommerce payments ) and then save changes, but on my website, when i save and page is refreshing this changes disappear.

On old website its works fine, but there was only two languages, Estonian and Russian, on new website i have 3 languages, Estonian, Russian and English.

October 8, 2019 at 6:48 pm #4717663

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

As it works fine on a clean install, it may be a compatibility issue with another plugin or related with a server setting. In this case, the next step is to test with a copy of your website.

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you.

Kind regards,
Diego

October 8, 2019 at 9:03 pm #4718075

RCPlanet

Hi!

Its done. Hope you will fix the problem =(

Best regards

October 9, 2019 at 2:59 pm #4723897

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

On our test server it worked as expected. I was able to disable and enable without issues. Could you please take a look? I sent the credentials on the previous message (private reply).

I suspect this is a cache related issue. Please try the following:
- Disable all caches (server/WordPress/browser)
- Disable the cache plugins (e.g. wp-rocket)
- Disable WP_CACHE on the wp-config.php file ( define('WP_CACHE', false); )
- Check if the issue still occurs.

Please let me know if it worked for you. If not, you can also test with the new string translator (WPML Beta versions). You can download here: https://wpml.org/account/downloads/ - IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Kind regards,
Diego

October 9, 2019 at 3:13 pm #4723961

RCPlanet

Good day!

Yes, i have checked your test version, there plugin works fine, but main page shows many errors.

I have allready tested by disabling all plugins and turning on one by one plugin. And this problem appeared when i turn on WPML String Translation plugin.

Im also tried to disable all cache plugins, problem was same. Right now have completed all your steps, issue still occurs.

=( Hope you can help.
Mby i can give you access to my website? Its in technical service right now, so people dont see nothing, because payment system is not working. And i have made DB and website backup.

I have also tried new WPML versions, right now on website is Beta version.

October 9, 2019 at 6:14 pm #4725115

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sure, Please send us access to your WordPress dashboard (website URL, login and password) and FTP credentials. I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Kind regards,
Diego

October 9, 2019 at 6:34 pm #4725145

RCPlanet

Wow, i dont know what i did, but now payment is working! O_O

But now another problem... In each language page, My account endpoint link is same...
Do you know what it is?

October 9, 2019 at 6:41 pm #4725171

RCPlanet

No, problem is not gone... Can you send private message again please?

October 9, 2019 at 7:19 pm #4725235

RCPlanet

Its worked when i activated " Look for strings while pages are rendered ", but when i deactivated it, payment system stop working...

October 10, 2019 at 1:49 pm #4731041

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I've enabled the private reply field again (for credentials), in case you need more help with the issue.

Regarding the issue with the my account endpoints, may I kindly ask you please to open a new ticket for your additional question? This will help other users with similar problems to find solutions when searching the forum.

Kind regards,
Diego

October 17, 2019 at 6:25 am #4770339

RCPlanet

Very slow support this time, i have solved this issue by myself at 10 october.

Hope next time i will have more better support...

October 17, 2019 at 6:27 am #4770341

RCPlanet

My issue is resolved now by myself.