This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by giuseppeS-24 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
September 8, 2018 at 5:53 am

stefan-adrianK

Hi,

I am having an issue with WPML and String Translator, it makes my site extremely slow.
If I deactivate WPML and String Translator my site gets really fast again.

I searched for previous tickets on this topic and have seen that a lot of users have these issues and that it takes a lot of time to get somewhere, if one's lucky.
The hoster has a server sided cache system which makes the site really fast. However, WPML is slowing everything down.

I dont have time to get this sorted out through weeks or months in the support forum as with other users.
Please give this ticket directly to second tier support.

If you can not debug this problem on the site I would like a refund as soon as possible.

Regards,
Stefan

September 8, 2018 at 7:12 am #2716580

stefan-adrianK

P.S. I have Wordfence active on the site, so if you wish to log in, you will have to tell me from which country you want to log in so I can whitelist the country

September 11, 2018 at 8:25 am #2722839

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please upgrade your MySQL version to 5.6(if you are not using MariaDB), the minimum required MySQL version for WPML and the recommended version for the WordPress. Then check is there any improvements in the performance or not. Please check following links for more details.

https://wpml.org/home/minimum-requirements/

https://wordpress.org/about/requirements/

Which Hosting service you are using? Is it a shared hosting space? I am trying to access your site from India. Please grant me permission to access your Dashboard.

I have a request. It will be great if you can consider staging site(clone copy of the live site) on the same server. So we can do the performance debugging without affecting your live site.

--
Thanks!

Bigul

September 14, 2018 at 7:39 am #2734325

stefan-adrianK

Hi Bigul,

I am meeting all the requirements for WPML to work in optimal conditions.

In the meanwhile I restricted the site via Whitelisting as there is sensitive Information on it.
Please tell me your external IP Address, only that way can I grant you access to the site, by whitelisting the external IP.
As long as you dont restart your Hardware, the external IP, if its dynamic, should stay the same for a couple of hours or days.

After you have looked at the site, I can also make a clone and give you access to it.
Please tell me your external IP.

Regards,
Stefan

September 14, 2018 at 12:23 pm #2735309

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates. My IP address is dynamic and currently, it is 112.133.229.22. Please check and let me know your feedback.

It will be great if you can consider a clone of the live site. So we can do the performance debugging in the same environment without affecting your live site.

--
Thanks!

Bigul

September 14, 2018 at 12:45 pm
September 14, 2018 at 1:24 pm #2735477

stefan-adrianK

Also a Screenshot of Query Monitor with the slow queries attached to this message.

September 14, 2018 at 3:49 pm #2736063

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates and login information. But I am not able to access your site. It is showing the following error. Please check.


This site can’t be reached

********.******.de took too long to respond.

Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

ERR_CONNECTION_TIMED_OUT

--
Thanks!

Bigul

September 14, 2018 at 6:31 pm #2736430

stefan-adrianK

Hi Bigul,

Can you please look if your external IP is still the same?
It is whitelisted, the site should be accessible.

Regards,
Stefan

September 17, 2018 at 7:13 am #2739824

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

For your kind updates, the IP is changed to 112.133.236.3 now. But I can't access the backend or front end of the test site. In both cases, it is showing the following warning. Please check.


This site can’t be reached

********.******.de took too long to respond.

Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

ERR_CONNECTION_TIMED_OUT

Sorry, the IP changes here randomly even if there is an interrupt in the connection.

--
Thanks!

Bigul

September 17, 2018 at 7:26 am #2739892

stefan-adrianK

Hi Bigul,

I just added the new IP to the Whitelisting. Please try again.

Gruß,
Adrian

September 17, 2018 at 8:15 am #2740089

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates. I can log in to the site now. I went through the backend and frontend pages of the site. The Pages are loading for me 2-3 seconds. So in which page/section you are facing the least performance. Please check the attached images for more details.

Are you using a shared hosting or VPS for hosting the site?

Because of the IP issues, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 17, 2018 at 8:20 am #2740184

stefan-adrianK

Hi Bigul,

yes, please make a copy with duplicator.
We experience issues with latency in the frontend as well as the backend.

You can see in the query monitor that some pages need longer than others to load. The query monitor is in the admin wordpress bar.

Also I think that you already did something, I experience some pages reacting faster on the clone. Please tell me what was done to improve the speed.

Regards,
Stefan

September 17, 2018 at 9:41 am #2740470

stefan-adrianK

Hi Bigul,

can you please keep me updated with what you find while testing on the local server?

Regards,
Stefan

September 17, 2018 at 4:39 pm #2741880

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the feedback. I haven't made any changes in your clone site, only visited the Pages in the backend and the frontend. All the pages are loading for me in 2-4 seconds.

I made a Duplicator copy and do the same tests on my local server. The pages are loading for me in 2-4 seconds. Please check the attached images.

Are you getting more time for loading on your end? Which page/section is taking too much time for loading? How much time it will take normally?

Also please check the following on your live site for a better understanding.

a) You have only included three string domains for auto-registering in WPML > String translation - hidden link

b) Visit WPML>>Languages>>Make themes work multilingual and make sure *Adjust IDs for multilingual functionality* option is selected or not

--
Thanks!

Bigul