This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Woocommerce checkout is very slow

Solution: Our specialists in the 2nd tier tested the site with the latest version (beta v4.0.0) and the issue is solved.

Relevant Documentation:

100% of people find this useful.

This topic contains 32 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 21, 2018 at 9:40 pm #1491291

JP

Since 2 weeks I experience a very slow checkout process with woocommerce.
It takes 6-20 seconds for the site to process the order.

When I disable all the WPML plugins, the speed is back to normal 2-5 sec.

However, when I activate the WPML plugins, the time for the server to start responding increases to an average of 6-8 seconds!!! The total time before the checkout page is back to normal again is sometimes 15-20 seconds! This is confusing and annoying for my users!

Please assist in this matter?

Thanks JP

January 22, 2018 at 7:29 pm #1492694

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello JP,
Thank you for contacting WPML support.

1.- This issue may be caused by a conflict between plugins. Please follow this steps:
- Make a full backup of the site before making any change, for security reasons.
- Update all outdated plugins, themes and core if corresponds.
- Flush all cache memory.
- Deactivate all plugins except WPML, Woocommerce and Woocommerce Multilingual plugins.
- Activate a default WordPress theme, like Twenty Seventeen.
- If the issue disappeared start activating the theme and then the plugins one by one until you see the issue again.

Could you tell me the result of this steps?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

January 23, 2018 at 11:35 am #1493647

JP

Dear Carlos,

Thank you for helping me in this.
I did as requested, but I see that activating the plugins one by one does not really impact the increase in load time. The total impact is 1,5 sec. Changing the theme does not help also.
When I am finished re-activating all plugins after some test orders the page response increases from 5 to 15 sec. The only effective way to go back to the normal response time is deactivating WPML. Then the response time and speed is back to normal again. When I reactivate WPML, the site response time is very low again.
So yes, I think there might be a conflict somewhere with WPML, but I can not find a specific plugin when I use inspector.

Please assist?

January 23, 2018 at 1:54 pm #1493908

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

Could you shre a download link with a copy of the site? This way I can make further tests on a local environment and isolate the cause of the issue.

I have set your next answer private, which means that only you and me will have access to the information.

Note: Please make the copy of the site using Duplicator plugin or All-In-One WP Migration plugin. In any case, don't include the media library as we don't need it for the tests.

Kind regards,
Carlos

January 24, 2018 at 2:19 pm #1495498

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

As soon I installed the site on local I got this error message: "Warning: Declaration of Raneri_Free_Shipping::calculate_shipping($package) should be compatible with WC_Shipping_Method::calculate_shipping($package = Array) in C:\Users\carlo\Desktop\xampp\htdocs\jp\wp-content\plugins\woocommerce-raneri-free-shipping\woocommerce-raneri-free-shipping.php on line 31"

Please follow this steps and let me know if the issue disappeared:
- Update all outdated plugins and themes.
- Deactivate the 'WooCommerce Raneri Free Shipping' plugin.
- Go to Settings -> Permalinks -> Re-save the permalink structure.
- Go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button.

Please let me know the result of this steps.

Note: Don't forget to make a full backup of the site before making any change, this is for security reasons.

Kind regards,
Carlos

January 24, 2018 at 3:03 pm #1495554

JP

Dear Carlos,

Thank you for your message.

I did not receive any messages in the past on the back-end that there might be a conflict with this plugin.

-All plugins and themes are up to date (except Layer Slider, which comes with the theme)
- I deactivated the WC Renari Plugin
- I re-saved the permalinks
- I cleaned the WPML cache.

I ordered some products on the site and checked the loading time of the checkout page. The processing time did not improve, it it still the same and very slow.

(feel free to login yourself and do some tests with ordering. use bank transfer payments....

Thanks JP

January 24, 2018 at 10:01 pm #1496083

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

I ran another set of tests in the local copy of the site. This time I followed this steps:
- I deactivated all plugins except WPML, Woocommerce, Woocommerce Multilingual and Fusion plugins.
- Re-saved the permalink structure in Settings -> Permalinks.
- I went to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button.

After finished this steps I made a full purchase and the performance was better. Could you repeat this steps in a staging site (this way we don't affect the live site) and let me know the result on your end?

If the issue persists, I would like to ask you to activate the debug mode in the site: https://codex.wordpress.org/Debugging_in_WordPress and share the content of the debug.log file that is located in wp-content folder.

Kind regards,
Carlos

January 24, 2018 at 11:08 pm #1496149

JP

Dear Carlos,

The site you have is my test site! That is why I gave you access to try it out....

The settings you tested do work indeed and give faster. I used this combination already 2 days ago when I followed your advised procedure, to start with minimal settings. The problem is created with more plugins active, as you can see on the back end of my test site. Then the checkout page is slow with WPML (12-17 sec) but fast without WPML (5-6 sec) .....

I activated the debug mode in the wp-config.php file as requested with:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true );
define('WP_DEBUG_DISPLAY', true );

I did run an order on the test site, but when I check if there is a debug.log file I can not find this file using hidden link. Do I something wrong?

In the meatine I also installed Query Monitor on the test site

Thanks JP

January 25, 2018 at 4:49 am #1496259

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

I ran the tests again on the test site. The performance issue seems to be caused by this two plugins:
- Booster Plus for WooCommerce
- WP Disable

Please see in the attached image the loading time of the checkout process with the mentioned plugins deactivated.

Note: The credentials you provided can't access WPML backend.

Please let me know your feedback.

Kind regards,
Carlos

January 25, 2018 at 7:53 am #1496377

JP

Dear Carlos

I tried to reproduce your steps But i have different results.

Please see annex. Without the 2 plugins I see three slow WPML actions? With the plugins I do not see them.

With backend you mean FTP? you could enter the website itself I think as both plugins were disabled when I logged in? If you make the next reply again private I will send you the credentials again.

Thanks JP

January 25, 2018 at 1:15 pm #1496891

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

What I mean is the credentials you shared can't access WPML dashboard in the backend of the site. I can't see the configuration of WPML.

I have set your next answer private for you to send the credentials again.

Regards,
Carlos

January 26, 2018 at 2:42 am #1497655

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

1.- I consulted my colleagues about the issue regarding the access to WPML dashboard. To solve it you must follow this steps (I would fix it myself but FTP credentials doesn't work for me):
- Copy this code into the functions.php file inside yout theme's folder:

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

- Then load the frontend of the site and remove the code from the functions.php file.

2.- Regarding the performance issue, I have escalated this ticket to our 2nd tier of support. Our specialist in the 2nd tier will try to isolate the cause of the issue and find a solution.

I will get back to you as soon as I have an answer from them.

Thank you for your patience.
Kind regards,
Carlos

January 26, 2018 at 8:59 am #1497827

JP

Dear Carlos

I did as requested and it worked.

Your credentials now show the WPML settings.

I wait for further response from you.

Thank you, JP

February 20, 2018 at 6:26 am #1523050

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JP,

I got a suggestion from our 2nd tier supporter. It seems that erasing the 'cache' folder increase the speed of the site. I have tested it on local and you can notice the change right away.

Could you erase the 'cache' folder inside wp-content folder and let me know if you see any change?

Looking forward to your answer.
Kind regards,
Carlos

February 20, 2018 at 12:42 pm #1523540

JP

Dear Carlos,

This folder contains the cached pages generated by the cache plugin or by theme. I am willing to empty this folder, but then new pages will be cached as soon as I use the website, so can you explain to me what will happen then?
I mean, a caching plugin serves to let the website load faster on pages which are cached. Are you asking me to stop using a caching plugin so my whole site will be slow then?

thanks JP