This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Lauren 6 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
April 10, 2019 at 2:03 pm #3577057

kirilsK

I am trying to: send pdf invoice in default language to Latvian and Russian speaking customers. In WooCommerce PDF Invoices & Packing Slips Professional --> Pro settings --> Multilingual settings, I have set: Site default language.

Link to a page where the issue can be seen: no link as it is a pdf.

I expected to see: PDF sent in Latvian language (default)

Instead, I got: a mix of two languages (please see an attachment)

April 10, 2019 at 5:28 pm #3579405

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

As mentioned in our earlier chat, please try to add your own translation to the "Shipping" string instead of the one that is coming from the .po file. Then check the box to use your translation and click save. Let me know if this shows correctly on the PDF that gets sent to the client.

April 10, 2019 at 5:35 pm #3579577

kirilsK

I have tryed what you sayed. Unfortunately that didnt change anything

April 10, 2019 at 5:56 pm #3579995

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I checked your settings and although you had checked "use my translation", the translation was still showing the Russian translation. You missed a step. If you don't want to show the Russian translation, you need to override the translation with the Latvian translation for Shipping. So, as you can see in my screenshot, I added "Piegāde" as the translation for Russian, even though it is not Russian. This way, when the PDF is sent, it sends in the Latvian language no matter which language the order was purchased in.

I checked and this time when I sent the PDF invoice to myself, the word "Piegāde" showed. Please confirm this is what you are seeing on your end, as well. Thanks!

April 10, 2019 at 6:09 pm #3580111

kirilsK

Thank you. Yes that did work. Unfortunately I've just tryed it doesn work with others.

April 10, 2019 at 6:10 pm #3580137

kirilsK

Where it says Выбранный посылочный терминал means Chosen Terminal

April 11, 2019 at 3:41 pm #3589907

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please send me a screenshot of where you are seeing this. Also, I checked your string translation table and as you can see from my screenshot, the Russian translation is set to "Выбранный посылочный терминал". If you want that to show in Latvian, then you need to paste the Latvian translation into the field for the Russian translation, just as we did earlier on the Shipping translation.

April 11, 2019 at 7:29 pm #3592405

kirilsK

Thank you for helping me. I think I've fixed it, just by changing the plugin. I have only one thing that is annoying me and I cannot do anything with it to change. Please see an attchmen. The text means Shipping. It is at the checkout page. Could you also please hide my invoice as there is my website form the firs post.

April 11, 2019 at 10:17 pm #3593135

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I wonder if the changes that we made for the invoicing (setting the Russian translation to Latvian) is causing this. I think the PDF invoice pulls from the WooCommerce translated text, which would explain. To test, can you try changing the string for Shipping back to the Russian term and see if it changes it here?