This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 4 voices.

Last updated by Muriel 2 years, 6 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
February 22, 2017 at 4:58 pm #1214891

Muriel

I have a smililar problem like https://wpml.org/forums/topic/how-to-setup-supercache-with-the-difference-domain-per-language/#post-1068959

SiteURL hidden link
HomeURL hidden link
Both of them should be the same?

AND I have tried to set the URLs to the Dutch Domain (as this is the primary language), in settings in wp-admin -> Settings -> Reading , but it "jumps" back to what it was before.

I hope this will then also solve my issue that de homepage on the .com site does not show the images and on the .nl site it does.

February 23, 2017 at 9:08 am #1215323

Dat Hoang

They're all fine under my eyes: all images are displaying.

Can you please check again and take some screenshots to show the issue?

February 23, 2017 at 9:36 am #1215370

Muriel

Weird, yesterday all day it did not want to laod them.
I also get that the home page loads the URL admin-ajax.php?lang=nl 12 times?

February 24, 2017 at 2:56 am #1216221

Dat Hoang

I'm sorry. I checked again and both pages are still good.

I also get that the home page loads the URL admin-ajax.php?lang=nl 12 times?

=> I don't think it might matter with WPML. Checking the inspector, all these AJAX requests are fired by Visual Composer.

March 3, 2017 at 11:51 am #1221751

Muriel

I have sent this info to the developer of the theme. Waiting for more info.

March 6, 2017 at 3:39 am #1222797

Dat Hoang

Please update me when you have more info.

March 20, 2017 at 9:09 pm #1235142

Muriel

Theme developer does not react at all.

March 21, 2017 at 8:57 am #1235428

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Dat is not available, so I am taking care of this ticket, Hope everything is Ok. 🙂

As Dat already mentioned the issue might not be related to WPML, would you mind testing the following so we can know which plugin/theme is creating issue.

If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

I look forward to your reply.

Thanks

March 21, 2017 at 9:03 am #1235435

gilB-2

Everything is OK now, thank you, Gil

March 22, 2017 at 3:54 pm #1236987

Muriel

We'll close this ticket for now, because I am starting to think that this is a visual composer issue. And as this is included in the theme, the issue starts between visual composer and the theme developer, who needs to fix it. 🙁