This thread is resolved. Here is a description of the problem and solution.

Problem: All works ok. The only thing is that when i change language the message "Your cart is empty" from cart doesn't change to the new language as should be.

Solution: Our development team released a new version of Woocommerce Multilingual that contains a solution for this issue. Could you install the newest version of the plugin and test if the issue is solved?

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 28 replies, has 3 voices.

Last updated by Vasileios Chouliaras 2 years ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 2, 2018 at 1:57 pm #1934177

Vasileios Chouliaras

Hi i have a problem with wpml and wprocket.
All works ok. The only thing is that when i change language the message "Your cart is empty" from cart doesn't change to the new language as should be.I have English and Greek.

When I join for the first time with eng language the message remains at English when changes to Greek

When I join for the first time with gr language the message remains at Greek when changes to English.

When wprocket is disabled this is not happening.

I talked with them and they told me that this is an issue with wpml.

At string translation is already translated.

Thanks

May 3, 2018 at 3:00 pm #1961284

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

It sounds like a caching issue with WP Rocket. Can you disable WP Rocket caching and see if the issue is still happening?

Also, please go to WPML -> Languages and scroll down to the Language Filtering for Ajax section. Check the box to enable "Store a language cookie to support language filtering for AJAX".

Let me know if this resolves the issue. To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

May 3, 2018 at 4:45 pm #1963450

Vasileios Chouliaras

Hi thanks for your reply.
I deactivated the wprocket and still the same.
the problem remains. String is translated.

This

Also, please go to WPML -> Languages and scroll down to the Language Filtering for Ajax section. Check the box to enable "Store a language cookie to support language filtering for AJAX".

is already activated.

So remove this i said, "When wprocket is disabled this is not happening."

The strange is that

"When I join for the first time with eng language the message remains at English when changes to Greek

When I join for the first time with gr language the message remains at Greek when changes to English."

May 3, 2018 at 10:03 pm #1966701

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Is this the page you are seeing the issue on hidden link? Because when I view this page and change languages, I see the correct translation the first time I switch languages. I am using the language switcher to change language. If you are seeing something different, please walk me through the steps you are taking and also let me know which browser you are using.

May 4, 2018 at 1:48 pm #1976200

Vasileios Chouliaras

At home page i checked and still the same.

May 4, 2018 at 3:02 pm #1978191

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This is not the same string mentioned in your original post - have you translated this string in the String Translation? Also, is this cart icon and pop up coming from your theme, or is it coming from a plugin? Is there somewhere in the settings where you create this message?

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

May 17, 2018 at 5:14 pm #2180461

Vasileios Chouliaras

Hi and thanks for your reply. Please make it private.
Thanks

May 18, 2018 at 12:40 pm #2189047

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The next reply has been marked as private. Thanks.

May 21, 2018 at 7:44 pm #2203976

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried to login but I get the following error message. Please double check credentials and update as needed. The next reply is marked as private.

May 22, 2018 at 1:23 pm #2208462

Vasileios Chouliaras

Thanks for your reply. please try again. was the firewall. now deactivated.
Thanks

May 22, 2018 at 4:20 pm #2210340

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I found that when I scanned WooCommerce and the child theme for strings, I found the "No products in the cart." string. I then added the translation and now it is showing correctly. You will need to clear your cache to see the changes. I have attached screenshot.

Please let me know if you need any further assistance and I will be happy to help.

May 23, 2018 at 1:11 pm #2215614

Vasileios Chouliaras

Thanks for your reply.
If you test on cached version it doesnt work.
The site was in offline mode. Try now to see

May 24, 2018 at 1:22 pm #2223184

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this to our 2nd Tier Support team. I will be working with the developers to find a solution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.

May 24, 2018 at 2:57 pm #2223736

Vasileios Chouliaras

Thanks for your help.
Inform me pls when you will have some news

May 24, 2018 at 3:29 pm #2224203

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Absolutely, I will inform you just as soon as I have more information 🙂