This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 24, 2019 at 11:58 am #3672351

sorenD-2

For newly created posts it works with choosing "Set prices in other currencies manually", but when chosen on older products, it deletes the written "regular price" and reverts to automatically calculate price after updating the product page.

I have tried
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations
-- Disable the Multi-Currency option in WooCommerce > Multilingual WooCommerce and then save the products and enable this option again.

April 24, 2019 at 7:19 pm #3676247

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

April 25, 2019 at 8:29 am #3680111

sorenD-2

I made a backup.
deactivated everything except WPML - CMS Nav, Media, Multilingual CMS, Sticky Links, String translation, Translation Management.
changed to theme twenty seventeen.
issue was still there.

entered the code in wp-config.php
still have the problem.

it seems that it affects every product created before 2019/04/23

April 25, 2019 at 8:47 am #3680205

sorenD-2

I tried creating a new currency (USD) and with that, I can change the price manually, so it might just be Euro there is something wrong with.

April 25, 2019 at 3:49 pm #3684161

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Could you tell me if the issue persists if you remove the Euro and add it again?

Also, I would like to ask you to follow this steps:
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all the products.
- If the issue persists then go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps (buttons) that are pointed out in the attached image.

Could you tell me the result of the steps above?

Regards,
Carlos

April 26, 2019 at 8:06 am #3688681

sorenD-2

removing euro and recreating it made no difference.

Synced all products.
applied all troubleshooting steps.
All of them said done, except "Fix post type assignment for translations" which just said there were none to fix.

Afterwards it still does not want to make a manual currency.

April 26, 2019 at 1:37 pm #3691017

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

April 29, 2019 at 7:21 am #3700473

sorenD-2

I dont see any fields except from the normal reply field?

April 29, 2019 at 10:31 am #3702115

sorenD-2

i only have this field

April 29, 2019 at 7:10 pm #3706279

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Maybe there was an error in my previous message.

I have set your next reply answer and you should be able to see the private fields this time.

Looking forward to your message.
Regards,
Carlos

April 30, 2019 at 8:04 pm #3714719

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I was able to access the site correctly and the credentials shared with another colleague shouldn't cause any issue.

I kindly ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes, specially Woocommerce Multingual.
- If the issue persists then re-save one of the products with the issue and update the translation.

Does the issue persists in that particular product?

Regards,
Carlos