Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Harshad 6 years, 1 month ago.

Assigned support staff: Harshad.

Author Posts
September 2, 2014 at 11:02 am #461912


I am trying to: Update WPML

I am logged into the repository but it does not allow me to update, can you please explain how the process is supposed to work?

September 2, 2014 at 11:20 am #461926


Have you seen this page?

The page include step-by-step details of the process. If you see anything different in any of these steps, please tell us on what step and what you're seeing instead.

September 2, 2014 at 11:45 am #461949


You need to enter your sites license key in plugins page.

1. You will need it to create a site key in your account. The site URL starts with http or https. Then, log in to your account and click on My Sites.

2. Click on the button to add a new site

3. Paste the site URL that you copied from the registration box before (starts with http or https). Your site will be added. Then, click on the show key link to display the site-key

4. The ‘show key’ text will be replaced by your site’s actual registration key. Copy that value and paste it back into the registration box in WordPress.

5. After you register your site, you will see a confirmation message and a list of WPML’s components, which you can install.

September 3, 2014 at 10:33 am #462845


How do you get to the plugins admin page, I don't see anything saying admin anywhere on the plugins page?

September 3, 2014 at 10:39 am #462854


And where is the registration box in WordPress, I can't see any of this??

September 3, 2014 at 10:42 am #462857


After you install WPML on your site, go to the WordPress admin. On the left column, click on Plugins. This is the plugins admin page. There, you will see the first screenshot in the installation FAQ:

hidden link

Are you seeing this? If not, please upload here a screenshot of the plugins admin page (the page from which you activate plugins in WordPress).

September 3, 2014 at 10:50 am #462868


Nope, because I have already registered, but I do not see any options to update?

September 3, 2014 at 10:56 am #462874


This new auto-upgrade option is only available since WPML 3.1.7. It appears that you are using WPML 3.1.6. For this first update, please download and install manually from your account here in Next updates will show automatically in the plugins admin screen.

September 3, 2014 at 11:07 am #462883


So how do I manually update without losing all my data please?

September 3, 2014 at 11:10 am #462889


1. Log in to your account.
2. Go to the Downloads section.
3. Get all the WPML components that you need from there.
4. Unzip each file. A directory will be created.
5. Upload the unzipped directories to your site’s ‘wp-contents/plugins’ directory.

Your data will not be changed during this process.

Finally, log in to your site and go to the Plugins admin page. Now, you will see the message to register on this site.

This will be a one-time process. Next updates will come directly to your WordPress admin.

September 3, 2014 at 11:33 am #462904


If you prefer however to do a manual update please follow these steps:

1. Backup your database – see for example:

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

September 3, 2014 at 12:54 pm #462998


Ok I did that but my plugin admin still says version 3.1.6

September 3, 2014 at 1:01 pm #463006


Have you downloaded version from here and uploaded it to /wp-content/plugins folder manually via ftp?

The topic ‘[Closed] WPML Auto Update not working’ is closed to new replies.