This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by George Botsev 2 months ago.

Assigned support staff: George Botsev.

Author Posts
August 15, 2019 at 10:25 am #4400229

williamk-20

When I try to use the beta version of WPML for performance improvement reason, I got the error below sent by wordpress to my email, this happened when you click the Multi-Currency Tab on Woocommerce Multilingual. That tab is also not accessible, it shows error
The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Error sent by wordpress email :
An error of type E_ERROR was caused in line 1119 of the file /home/will/public_html/domain.com/wp-content/plugins/sitepress-multilingual-cms/lib/twig/src/Environment.php. Error message: Uncaught LogicException: A function must be an instance of \Twig_FunctionInterface or \Twig_SimpleFunction. in /home/will/public_html/domain.com/wp-content/plugins/sitepress-multilingual-cms/lib/twig/src/Environment.php:1119
Stack trace:
#0 /home/will/public_html/domain.com/wp-content/plugins/sitepress-multilingual-cms/classes/templating/class-wpml-templates-factory.php(120): WPML\Core\Twig\Environment->addFunction(Object(Twig_SimpleFunction))
#1 /home/will/public_html/domain.com/wp-content/plugins/sitepress-multilingual-cms/classes/templating/class-wpml-templates-factory.php(67): WPML_Templates_Factory->maybe_init_twig()
#2 /home/will/public_html/domain.com/wp-content/plugins/woocommerce-multilingual/inc/template-classes/class-wcml-menus-wrap.php(223): WPML_Templates_Factory->get_view()
#3 /home/will/public_html/domain.com/wp-content/plugins/woocommerce-multilingual/inc/template-classes/class-wcml-menus-wrap.php(173): WCML_Menus_Wrap->get_current_menu_content('multi-currency')
#4 /home/will/pu

August 15, 2019 at 12:52 pm #4400865

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello and thank you for contacting us!
Indeed there is a problem with the latest beta of WPML, and the latest stable release of WooCommerce Multilingual.
However that is because we have still not released the new version of WooCommerce Multilingual.
We have plans to make that release tomorrow.
Until the new release, please don't use WooCommerce Multilingual with the latest beta of WPML.