This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by fabioT-6 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 7, 2020 at 6:07 pm #5860295

fabioT-6

Actually I have the same issue of this topic:
https://wpml.org/forums/topic/bundle-products-are-not-displayed-in-the-translation-languages/

But in WPML > Settings > Custom Field Translation I don't have any field that starts with "woos", I tried to apply the instructions to "copy" to the attributes attached, but the problem still not solved.

Can you please help me.
Thank you

April 8, 2020 at 8:16 pm #5869811

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before providing you with a more accurate reply please, let me know in which product I can see the issue happening and which are the missing parts.

Also, when setting the translation choices to 'copy' for the custom fields you need to update the product in the default language and then change to the secondary language and click the update button as well in order to make the changes to take effect, did you make this way?

Please, let me know the results, have a nice day.

April 9, 2020 at 3:20 pm #5877371

fabioT-6

Hi Marcos, updated the product in all languages but nothing seems to change.
This is the link to the product:

English (default lang.) How it should be (I can choose sizes of the bundled products):
hidden link

Italian (The bundled products aren't synced):
hidden link

The same on the other languages: German, French, Spanish, Portuguese

April 9, 2020 at 7:41 pm #5879195

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 14, 2020 at 12:05 am #5899339

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look at your WordPress Dashboard settings and actually it seems we have a products attributes sychronization issues, please, try the following:

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - Go to your WordPress Dashboard > WooCommerce > WooCommerce Multilingual > Status and click the blue 'Troubleshooting' link at the bottom right of the screen.

2 - From the Troubleshooting options click the variable products synchronization options to keep your products attributes sychronized.

3 - If the issue persists, go to your WordPress Dashboard > WPML > Support and click the blue 'Troubleshooting' link, now proceed to the 'Synchronize posts taxonomies' for the 'products' post type.

Note: a backup is required as stated above for this kind of troubleshooting, even better if you can apply these steps for a staging website before applying it in your live website.

Please, let me know if it works for you, have a nice day.

April 14, 2020 at 10:39 am #5903353

fabioT-6

Hi Marcos, just completed both the options and nothing changed.

In WPML > Support I found that I have PHP version 7.1 instead of 7.3, don't know if this is influencing all this issue.

Waiting for your instructions.
Thank you

April 14, 2020 at 12:16 pm #5904087

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the migration process is done. Thanks.

April 14, 2020 at 2:19 pm #5905179

fabioT-6

Hi Marcos, migration completed.

April 17, 2020 at 1:12 am #5927779

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried an extensive investigation in the migrated website, unfortunately the issue persists, I am consulting our second level support for a more detailed look. As soon as I have some more details from them, I will update you here. Thank you for your continued patience and understanding, have a nice day.

April 17, 2020 at 10:19 am #5931589

fabioT-6

Ok Marcos, I'll be here available, thank you
Have a nice day.

April 17, 2020 at 7:06 pm #5935217

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience while waited for a solution. I've made some more tests in the migrated website and noticed everything works fine in a new created product. I created a test product with the same bundled products and it works properly for the translation as you can confirm at:

English: hidden link

Italian: hidden link

Do you see the same issue for any other product or just the particular product at: hidden link?

Can you please, recreate it as new product post and add a italian translation for it? In order to save you some effort you can copy and paste the translation you have already done for the problematic product post.

The purpose here is to confirm if there's any corrputed database data for this product only which could be preventing it from working properly with its bundled product settings.

Please, let me know the results, have a nice day.

April 18, 2020 at 2:49 pm #5939493

fabioT-6

Hi Marcos, ok so you suggest to just recreate the product, right?
Then it should work?

Thank you

April 20, 2020 at 5:34 pm #5952465

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hi,

Thank you for the updates. According to my tests this issue is not reproduced in a new product, so in this case, yes, I recommend you to recreate it, as the issue could be related to some corrupted data for this product only. Please, let me know the results, have a nice day.

April 21, 2020 at 10:37 am #5958025

fabioT-6

Yess everything works fine now.
Thank you Marcos!

April 21, 2020 at 10:38 am #5958033

fabioT-6

My issue is resolved now. Thank you!