Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by pascalB-17 1 month, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
August 7, 2019 at 10:50 am #4354007

pascalB-17

I am trying to: save a page (in WP editor - not Elementor)

Link to a page where the issue can be seen: any page of the site

I expected to see: a saved page

Instead, I got: a "saving loop"

August 7, 2019 at 10:54 am #4354061

pascalB-17

Hello
I had started this support request already but it was closed for replies and I never heard back from support...
It might be helptful to know that the issue doesn't occur when the Plugin WPML Media is deactivated.

Esle WP generates this errors:
Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130
Stack trace:
#0 /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element))
#1 /home/zproduc2/www/z-productions.com/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(1872)
#2 /home/zproduc2/www/z-productions.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /ho

August 7, 2019 at 6:21 pm #4357311

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Possible the issue is between Media Translation and another plugin. Did you try it works with WPML and its add-ons only?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 12, 2019 at 5:24 pm #4382805

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe die Website nun längere Zeit lokal getestet und u.a. eine Seite erstellt, dieser ein Bild zugefügt und die Seite ohne Probleme übersetzt.

Ich konnte den von Ihnen erwähnten Fehler leider nicht replizieren. Könnten Sie bitte nähere Angaben dazu machen, in wie fern der Error die Funktionalität der Website beeinträchtigt?

Das debug.log zeigte hier allerdings einen anderen Fehler, bei welchem unklar bleibt in welchem Moment er aufgetreten ist:

WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_options ( `option_name`, `option_value`, `autoload` ) VALUES ('wpml.WPML_ST_DB_Cache.lock', '1565629499', 'no') /* LOCK */ made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wp_widgets_init, do_action('widgets_init'), WP_Hook->do_action, WP_Hook->apply_filters, WPML_LS_Widget::register, register_widget, WP_Widget_Factory->register, WPML_LS_Widget->__construct, __, translate, apply_filters('gettext'), WP_Hook->apply_filters, icl_sw_filters_gettext, icl_translate, WPML_Register_String_Filter->translate_by_name_and_context, WPML_Displayed_String_Filter->get_translation, WPML_ST_DB_Cache->get_translation, WPML_ST_DB_Translation_Retrieve->get_translation, WPML_ST_DB_Translation_Retrieve->load, WPML\Utilities\Lock->create

Ich werde unseren Level 2 Support kontaktieren, um weitere Anweisungen zu erhalten.

Mit freundlichen Grüßen
Andreas

August 14, 2019 at 11:32 pm #4398001

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das Problem ist unseren Entwicklern bereits bekannt und Ihre Angelegenheit wurde weitergeleitet. Ich werde mich bei Ihnen melden, sobald wir eine kurzfristige Lösung anbieten können.

Wir hoffe auf Ihr Verständnis und danken für Ihre Geduld.

Mit freundlichen Grüßen
Andreas

September 16, 2019 at 9:24 pm #4584257

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please try to update all WPML Plugins to their latest version by going to Plugins -> Add new -> Commercial.

If this will not solve the issue please change from "stable" channel to "beta" channel and install all our Beta versions.

Let me know if this solved the issue.

Kind regards
Andreas

September 22, 2019 at 3:40 pm #4618899

pascalB-17

Hi Andreas

Thanks for your reply.
I did the regualr update but unfortunately this didn't solve the issue.. it still causes a fatal error in WP.
I haven't gone with the beta version yet as it seems likely that it will create new issues.. and unfortunately I don't have the time to deal with this right now.. is there an e.t.a on when the beta version will go live?

Thanks, Pascal

September 24, 2019 at 12:23 am #4626895

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

*MESSAGE SEND BY ERROR*

September 24, 2019 at 12:30 am #4626899

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Our developers are still working on the issue.

Anyhow, they suggested trying the Beta version as it should be able to solve the issue in the meantime. I will be in contact as soon as I receive a workaround.

Also, they advise to take a backup of the site and try to run the WPML troubleshoot options at WPML -> Support.

Let me know if you need any assistance with this task. If you wish I can also take a copy of the site to test it with the beta, but it would be ideal if you could provide access to a staging site.

Thank you for your patience.

Kind regards
Andreas

October 11, 2019 at 1:09 am #4734497

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing to you to let you know that we released new versions of our plugins that should be able to solve the reported error on the wp-options table.

Unless you are already using our Beta plugins for WPML Multilingual CMS 4.3 could you please process the latest updates and let me know if the issue got solved?

Kind regards
Andreas

October 11, 2019 at 1:09 am #4734501

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing to you to let you know that we released new versions of our plugins that should be able to solve the reported error on the wp-options table.

Unless you are already using our Beta plugins for WPML Multilingual CMS 4.3 could you please process the latest updates and let me know if the issue got solved?

Kind regards
Andreas

October 11, 2019 at 2:29 pm #4739551

pascalB-17

Hi Andreas

Unfortunately nothing has changed and I still get a fatal error when I activate WPML Media and try to save a page

WP Error message:
Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130
Stack trace:
#0 /home/zproduc2/www/z-productions.com/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element))
#1 /home/zproduc2/www/z-productions.com/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(1872)
#2 /home/zproduc2/www/z-productions.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /ho

October 11, 2019 at 5:23 pm #4740583

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello

Your WPML plugins are not updates. Please activate the plugins.

Now, go to Plugins -> Add new -> Commercial -> Search for updates.

Then install and activate the latest plugin versions and let me know if the issue got solved.

Kind regards
Andreas

October 12, 2019 at 12:44 pm #4742949

pascalB-17

Hi Andreas

I'm sorry to say that it looks like my WPML plugins are updates. I still did as suggested and everything looks updated and the issue is still occurring...

October 14, 2019 at 5:17 pm #4752193

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe Zugang zur Website zd.teamswitzerland.com erhalten, auf welcher anscheinend ein Reset von WPML durchgeführt wurde.

Des Weiteren sind/waren hier WPML und weitere Plugins nicht auf dem neusten Stand.

Könnten Sie mir bitte Zugang zu einer Website geben, auf welcher das Problem mit den neusten Plugin Versionen auftritt?

Mit freundlichen Grüßen
Andreas