This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 30, 2019 at 10:29 am

vladimirJ-8

I am trying to: Finalise WPML translation including a menu with the anchor links

Link to a page where the issue can be seen: hidden link

The internal server error is displayed randomly on the pages from the menu.

This basically means that at some point, I am able to access the provided pages and in other times, the error is present.

Also, I was able to notice that upon each visit on my website, the (.htaccess) file is modified or changed.

And that's probably happening because WPML trying to set up the language based on my browser language therefore constantly changing the (.htaccess) file for example:

# de
# en

After a few visits to the website, the file in question was modified multiple times and each time, with different information. This caused the Apache web service to either temporary to read the file or to unable to read it. When the second is valid, an Internal Server Error is present due to "Too Many Internal Redirects".

I just want to simply achieve to make it work without any errors.

The last configuration I did with WPML was a change of the Language URL format from Language name added as a parameter to Different languages in directories and saving again the permalinks.

We are now just before final steps before we launch the EN version and this issue is currently the main step we need to manage.

July 30, 2019 at 4:40 pm #4309747

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I visited the site and applied some troubleshooting steps in WPML -> Support -> Troubleshooting link. I also re-saved the permalink structure.

If the issue persists I would like to ask you to activate the debug mode in the site by following the steps described in this link: https://codex.wordpress.org/Debugging_in_WordPress and check if there is any error message in the debug.log file.

Kind regards,
Carlos

July 30, 2019 at 10:06 pm #4310617

vladimirJ-8

Hello Carlos,

I have attached my debug log. I have also tried to disable the mentioned plugin yesterday but the results and errors were still the same. Even my hosting specialists took a look at the issue and they recommend me to contact directly WPML as this is related to the translations.

Here is the log copied:

[30-Jul-2019 21:57:35 UTC] PHP Notice: Undefined offset: 2 in /home/prohocke/jrhockey.co/wp-content/plugins/elfsight-instagram-feed-cc/api/elfsight-api.php on line 157
[30-Jul-2019 21:57:37 UTC] PHP Notice: Undefined offset: 2 in /home/prohocke/jrhockey.co/wp-content/plugins/elfsight-instagram-feed-cc/api/elfsight-api.php on line 157
[30-Jul-2019 21:57:50 UTC] PHP Notice: Undefined offset: 2 in /home/prohocke/jrhockey.co/wp-content/plugins/elfsight-instagram-feed-cc/api/elfsight-api.php on line 157
[30-Jul-2019 21:57:52 UTC] PHP Notice: Undefined offset: 2 in /home/prohocke/jrhockey.co/wp-content/plugins/elfsight-instagram-feed-cc/api/elfsight-api.php on line 157

July 30, 2019 at 11:47 pm #4310753

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I can see that the 'Elfsight Instagram Feed CC' plugin is throwing an error. If you deactivate this plugin, does the issue persists?

Regards,
Carlos

July 31, 2019 at 11:24 am #4313901

vladimirJ-8

Yes it persist.

July 31, 2019 at 12:20 pm #4314245

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

Could you provide the steps to reproduce the issue?

Regards,
Carlos

August 1, 2019 at 8:02 pm #4325013

vladimirJ-8

The error is happening on the page: hidden link sometimes when you click on the "store" menu item from the English homepage and if you manage to get on the english store page, then all the anchor menu items will give you the error always when you click on them:
STICKS
TOP SPECS
FLEX
BEGINNING
REGISTER STICK
GALLERY
EXPERIENCES
CONTACT

and sometimes also the FAQ page. To be clear all is from the hidden link

Hopefully, we will find the solution soon as we would like to launch the English version.

Kind regards,
Vadio

August 2, 2019 at 12:11 pm #4329827

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vadio,
Thank you very much for your feedback.

I solved the issue of the shop page by re-saving the translation that was un-finished. Once I did this step the store page loads correctly.

Regarding the other menu items, the cause of this issue is that this are anchor links that work in the default language but not in the secondary languages because they point to anchors (CSS IDs) that doesn't exists in the translated pages, specially in the homepage in the secondary languages. The best way to solve this issue is by manually translating the homepage and adding this CSS IDs. TO do so you need to edit the homepage in the default language -> Switch to the secondary languages using the admin menu on the top bar -> Click on 'Edit anyway' button -> Manually add the CSS IDs -> Save the changes.

Could you confirm that the issue is solved?

Regards,
Carlos

August 2, 2019 at 4:44 pm #4331543

vladimirJ-8

Hi Carlos,

I have tried that also before and now as well, but unfortunately still getting the error at this time I couldn't even go to the SHOP, FOR CLUBS, FAQ and CONTACT page.

To be clear you meant by the CSS IDs the anchor ids?

Best regards,
Vadio

August 2, 2019 at 5:36 pm #4331953

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vladio,
Thank you very much for your feedback.

After applying the WPML's troubleshooting steps I can see the pages in English again (see attached images). I suspect that there is a conflict between WPML and 'Elfsight Instagram Feed CC' plugin.

If you deactivate 'Elfsight Instagram Feed CC' plugin does the issue persists?

Regards,
Carlos

August 3, 2019 at 12:44 pm #4334529

vladimirJ-8

Hi Carlos,

I have disabled the plugin again and it's still happening.
What else would you suggest?

Best regards,
Vadio

August 5, 2019 at 1:23 pm #4340967

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vadio,
Thank you very much for your feedback.

In this case I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

August 5, 2019 at 3:54 pm #4341751

vladimirJ-8

Hi Carlos,

I found finally the issue, there is the incompatibility with the: Indeed Ultimate Affiliate Pro plugin (hidden link) Can anyone from your team find out if the issue is related to the WPML or their plugin?

Best regards,
Vadio

August 5, 2019 at 4:07 pm #4341851

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Vadio,
Those are really good news.

If you deactivate this plugin and the issue disappears then we are facing a compatibility issue with WPML. To be able to escalate this ticket to our compatibility team we will need to follow this steps:
- Reproduce the issue in a fresh new WordPress install that only contains WPML plugins and the Ultimate Affiliate Pro plugin.
- Contact the plugin's authors and let them know about this issue. Also, get some contact information from them and let them know that our compatibility specialists will contact them.

Please let me know when you finish the steps above so we can continue.
Regards,
Carlos

Note: In the case that you can create a test site, just let me know and I will create one for you.

August 6, 2019 at 2:29 pm #4348393

vladimirJ-8

Hi Carlos,

Yes I am kind of relieved too, we made a progress.
Can you please create the wordpress copy we can test it on and share the link with me please? I will upload the affiliate plugin there.

Thank you,
Vadio