This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 1 month, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
August 5, 2019 at 12:07 pm #4340413

rickyR-2

I am trying to: Editing a post

Link to a page where the issue can be seen: Back-end

I expected to see: Succesfull saving

Instead, I got: 503 Service Unavailable

In the php error log:

(70007)The timeout specified has expired: AH01075: Error dispatching request to :, referer: hidden link

All plugins are disabled. Only WPML is activated.

Server is apache+nginx with plesk, php7.2 FPM

Wordpress is up-to-date and WPML is up-to-date.

August 5, 2019 at 1:09 pm #4340715

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You have two issues: hidden link
Your hosting memory limit is 2G. That's fantastic but your WP memory limit is just 40 Mb

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '2048M');

Also, increase your MaxInputVars to 10000

Then check the issue.

Let me know how it goes.

Regards,
Riffaz.

August 16, 2019 at 9:43 am #4405723

rickyR-2

Hi Riffaz,

So I committed the changes you advised, but still a 503 error.

August 18, 2019 at 4:35 am #4411453

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Then we need to follow the troubleshooting process:

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here: hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

August 22, 2019 at 2:25 pm #4440227

rickyR-2

Hi Riffaz,

Still no luck.

All other plugins are already disabled. I can't activate the default theme because it is an custom post type that comes with the theme.

No console errors and debug.log is empty.

August 25, 2019 at 12:22 pm #4454029

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

This is something controlled by the server configuration.
Ask your hosting support to check the server log.
They can find the cause by checking the server log.
Then they will be able to fix this in a minute.

probably your hosting wants to increase the maximum execution time.
Just check with them first as I mentioned above.

Let me know how it goes.

Regards,

The topic ‘[Closed] WPML causing 503 Service unavailable, TimeOut specified has expired’ is closed to new replies.