This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 4 voices.

Last updated by rolandd-5 1 year, 3 months ago.

Assigned support staff: Jamal.

Author Posts
March 3, 2019 at 12:42 pm #3266154

Junior Milkievicz

Checkout takes several minutes:

01-Mar-2019 11:15:12] [pool …] pid 14818
script_filename = /.../index.php
[0x00007fec9941fdc0] mysqli_query() .../wp-includes/wp-db.php:2007
[0x00007fec9941fd40] _do_query() .../wp-includes/wp-db.php:1895
[0x00007fec9941fc60] query() .../wp-includes/wp-db.php:2254
[0x00007fec9941fb10] update() .../wp-includes/taxonomy.php:3702
[0x00007fec9941f9d0] _update_post_term_count() .../wp-includes/taxonomy.php:3133
[0x00007fec9941f910] wp_update_term_count_now() .../wp-includes/taxonomy.php:3105
[0x00007fec9941f850] wp_update_term_count() .../wp-includes/taxonomy.php:2651
[0x00007fec9941f730] wp_remove_object_terms() .../wp-includes/taxonomy.php:1717
[0x00007fec9941f680] wp_delete_object_term_relationships() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-duplication.class.php:227
[0x00007fec9941f590] duplicate_taxonomies() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-duplication.class.php:132
[0x00007fec9941f4a0] run_wpml_actions() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-duplication.class.php:102
[0x00007fec9941f330] make_duplicate() .../wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:4417
[0x00007fec9941f2a0] make_duplicate() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-synchronization.class.php:85
[0x00007fec9941f200] sync_with_duplicates() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php:176
[0x00007fec9941f130] after_save_post() .../wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-frontend-post-actions.class.php:45
[0x00007fec9941eff0] save_post_actions() .../wp-includes/class-wp-hook.php:288
[0x00007fec9941ef10] apply_filters() .../wp-includes/class-wp-hook.php:310
[0x00007fec9941eea0] do_action() .../wp-includes/plugin.php:465
[0x00007fec9941ed80] do_action() .../wp-includes/post.php:3951
[0x00007fec9941e960] wp_insert_post() .../wp-includes/post.php:4028

March 3, 2019 at 1:37 pm #3266220

Junior Milkievicz

FYI:

When we deactivate all plugins except WooCommerce it takes 6 seconds to checkout...
When we activate WPML it augments to 2 minutes and 15 seconds to checkout...
When we activate WooCommerce Multilingual it augments to 3 minutes and 07 seconds...

We've tried it with 2019 WP Theme (default) and it doesn't influence.

March 5, 2019 at 10:43 am #3272937

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. Our apologies for the late reply.

Please make sure to align with WPML requirements especially for MySQL version.
https://wpml.org/home/minimum-requirements/
This would give a performance boost to your website.

Can you also follow our article on how to prevent performance issues with WPML
https://wpml.org/faq/prevent-performance-issues-with-wpml/

Finally please follow this article on how to debug the performance issues and share your findings with us.
https://wpml.org/faq/how-to-debug-performance-problems/

Looking forward to your reply.

Best regards,
Jamal
WPML Support

March 5, 2019 at 2:21 pm #3274501

Junior Milkievicz

Thanks Jamal, we've looked through all three articles but the problem is really on the checkout page. The other pages load as they should. When there is only one article, it works, but multiple articles make the checkout very long. When we use the debug plugin on the checkout page it timeouts so we can't give any info about this.

This is our setup.

We use MariaDB 10.1 (MYSQL Ver 15.1 Distrib 10.1.38-MariaDB
PHP
Versión 7.2.15-0ubuntu0.18.04.1
Límite de memoria 256M
Uso de memoria 41.63 MB
Tiempo de ejecución máximo 300
Vars de entrada máx. 3000
Conjunto de caracteres Utf8mb4 Sí
Extensión Multibyte String Cargado
Extensión SimpleXML Cargado
WordPress Versión 5.1
Multisitio No
Límite de memoria 256M
Límite de memoria máximo 256M

We already provided debug information in the first post.

March 5, 2019 at 3:04 pm #3274762

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I can suspect the use of WordPress 5.1. As of now wpml.org is not yet running under WP 5.1.
I also checked woocommerce.com and they seems to be running WooCommerce 3.5.3 with WP5.1.

Can you revert back WordPress to 5.0.3 ?

Let me know what you can do ?

Best regards,
Jamal
WPML Support

March 5, 2019 at 11:09 pm #3276364

Junior Milkievicz

Dear Jamal,

Thanks for your suggestion but it didn't solve the issue. We've downgraded to 5.0.3, tested, no result, downgraded WooCommerce to 3.5.3, tested, no result. Then when maximizing memory the Debug Plugin started working (the one that previously checkouts) but the plugin is of no use for us because the problem starts when we hit the checkout button. Please help us to fix this; we can give you access.

March 6, 2019 at 5:12 pm #3280642

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies for the late reply. In this case, i would recommend sticking with WP5.0.3 and activating PHP debugging, and reproducing the error. I will download the file to investigate any errors in there. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/

We should also exclude the Checkout Field Editor plugin, maybe it is the cause as it is almost used only in the checkout page ?
If it is possible to check by disabling any plugin that is not used for front end rendering, i assume that plugins from Stock Management Labs™ can be deactivated just during the test.

I would also like to understand the source of the logs shared in your first message ?

Please ask your hosting provider about any caching system if enabled ?

Best regards,
Jamal
WPML Support

March 7, 2019 at 3:11 pm #3285152

Junior Milkievicz

It seems we've found a workaround. We've used the troubleshooting options inside WPML plugin and disabled stock management at inventory level. So apparently, stock management at inventory level is causing minutes of loading time in WPML... But I wouldn't call it resolved.

March 8, 2019 at 11:48 am #3291840

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. Sure this needs to be investigated more.
Have you been able to check if this is not caused by a conflict with other plugins. As i have suggested in my previous message.
If this is reproducible with only WPML, WooCommerce and WCML, we should absolutely escalate it to our WPML developers.

If this is caused by a conflict with the theme or another plugin, we may also approach our compatibility team for help.

Let me know if you were able to do these checks.

Best regards,
Jamal
WPML Support

March 8, 2019 at 12:31 pm #3292176

Junior Milkievicz

Dear Jamal,

Please check post-3266220, the second post of this thread. It's not being caused by another plugin.

March 8, 2019 at 4:10 pm #3294134

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies, i missed that in the previous messages.
In this case would you like to share a duplicator package of your website, i would approach our 2nd Tier team to analyse this further. If they spot a bug this would be escalated to developers for a fix.
Please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media, and the archive files, to reduce the size of the package. https://wordpress.org/plugins/duplicator/
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

Share the link to the archive file (you probably want to use Google Drive, Dropbox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.

Best regards,
Jamal
WPML Support

March 31, 2019 at 9:03 pm #3502627

Václav

Hello, same issue here. I can confirm that the problem is when I have the "stock management at inventory level" checked in product detail. Once I uncheck that, the checkout speed is normal.

This is an important bug, any chance to get this fixed, please?

March 31, 2019 at 9:41 pm #3502651

Václav

Hello again, I just downgraded to WCML 4.3.7 and the issue seems to be gone, or at least the checkout went from 35s to 9s.

The issue is present from v4.4. Should I open a separate ticket for this? Thanks

April 13, 2019 at 6:42 am #3603669

rolandd-5

Hi,

I have the exact same problem as Vaclav describes.

I can confirm disabling Stock management on the product, the checkout is back to normal to 3-5 seconds (was 10-15 seconds).

I also created a ticket:
https://wpml.org/forums/topic/bug-slow-checkout-when-stock-management-enabled-bug/

This is a major bug with the highest priority!!

Regards,

Roland

The topic ‘[Closed] WPML causing extremely slow checkout in WooCommerce’ is closed to new replies.