This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 5 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 24, 2019 at 2:58 pm #3674437

eurlG

I am trying to:Improve the loading speed of my back-end.
I disabled all my plug-in and then enable them anew with query monitor previously enable.

Link to a page where the issue can be seen:

I expected to see:My back end a little slowed by WPML

Instead, I got:My back-end more than two time slowed when all plug-in from WPML are enabled. Would it be possible to have WPML not working on the back-end pages when it is not useful such as the page where I have my order displayed?

April 24, 2019 at 10:37 pm #3677403

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

Please have a look at the following documentation and apply the recommended setting in order to optimize your site performance with WPML.
https://wpml.org/faq/prevent-performance-issues-with-wpml/

Further, it would be helpful if you could provide us more detailed information about slow queries. More information about debugging site issues you can find here.
https://wpml.org/faq/how-to-debug-performance-problems/

If the recommended settings will not solve the issue in an acceptable manner I can offer to escalate the issue to our developers.

In order to do so I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 25, 2019 at 3:47 pm #3684153

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Do I understand you right, that your site is translated from french to English? You might test if it has an impact on the response time if you change the default language to English, as many plugins use this language as default.

Further, the site login is not available as the URL ends in a 404 error. Could you please verify the URL for access to wp-admin? Please also make sure that the FTP access credentials are working, as I will need them to debug the site.

Kind regards
Andreas

April 26, 2019 at 7:02 am #3688121

eurlG

Hi,

I disabled all plugin from WPML and now the login URL works again.
The FTP credentials are right did you had a problem using them?

Thanks,
Mathias

April 26, 2019 at 1:32 pm #3690993

eurlG

I enabled again the different plugin from WPML and you can log in.
I tried to change the main language of my website but it create a huge mess due to the fact that the URL in french is now pierregignoux.fr/fr instead of pierregignoux.fr previously so I put it back as it was.
The problem is that for some product I cannot access the english translation and get an error 500, for example the "Race Pro" product. Could you please take a look at it?
Thanks in advance.

April 26, 2019 at 2:54 pm #3691703

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I tried to access the English translation for the product Race Pro and I received the same 500 error.

This error is most likely caused due to a compatibility issue between different plugins. Did this issue maybe appears suddenly after the latest update?

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given. You will find the three code snippets in the following documentation. Simply add them to your wp-config.php file and afterwards check for the debug.log file inside of the wp-content folder.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know if you are able to complete the tests, otherwise I will take a copy of your site or we migrate it to our test server if necessary.

Kind regards
Andreas

April 29, 2019 at 9:44 am #3701747

eurlG

Hi Andreas,
Sorry for the late answer,
I have tried to disable almost all plugin except for woocommerce and WPML I still get problems like a blank page for my english page on some product, and the website is quite slow.
I also have the debug report how can I send it to you?
Thanks,

April 29, 2019 at 12:59 pm #3703503

eurlG

Hi again,
I have updated the Woocommerce multilingual plugin and it seams to have successfully resolve my error 500 and/or blank pages.
But I still have a lot slower website while using WPML plugin compare to when I deactivate them. Is it possible to have my WP woorking in english instead of French (it indeed seams to be faster) but without the change in the URL, In french: pierregignoux.fr and in english pierregignoux.fr/en ?
Thanks for the help!

April 29, 2019 at 3:14 pm #3704847

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am glad to hear that the update was able to solve the 500 Error.

Now, when it comes to your site URL I would advise you to configure your server for a site URL structure that allows a different domain per language.

You might use the following structure:

hidden link --> Default English
hidden link --> French

More information about how to configure your DNS Server you can find here:
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Do not hesitate to contact your Host Provider for further assistance.

Once the server is configured go to WPML -> Languages -> Site URL Structure and choose "Different Domain per language".

About the performance issues please apply our recommended settings from the following documentation:
https://wpml.org/faq/prevent-performance-issues-with-wpml/

I hope this will solve the issue, otherwise please contact me again in order to debug your site.
https://wpml.org/faq/how-to-debug-performance-problems/

Kind regards
Andreas

The topic ‘[Closed] WPML CMS and WPML string translation more than double loading time on backend’ is closed to new replies.