This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to update the WPML CMS Plugin, and others as well. The error upon update appears on the CMS plugin. Solution: Uninstalling the WPML plugins and installing them back got everything back to normal. The plugins were installed back through FTP since some files were missing when trying to install them through WP dashboard.

This topic contains 13 replies, has 2 voices.

Last updated by andrewL-17 3 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
June 23, 2019 at 2:38 pm #4073177

andrewL-17

I am trying to: Update the WPML CMS Plugin, and others as well. The error upon update appears on the CMS plugin.

Link to a page where the issue can be seen: hidden link - on maintenance mode right now, can't undo because the website crashed completely.

I expected to see: A successful update.

Instead, I got: A website that I need to restore from a backup. It crashed for the second time and its the same plugin that crashed it.

June 24, 2019 at 1:11 am #4073673

andrewL-17

The plugin has completely destroyed the functionality of my website and is now offline. Now I do not have any translation strings working properly.

June 24, 2019 at 10:05 am #4076177

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

Sorry about this issue. Let's see what we can do about it. First of all, can you add this code:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_DISPLAY', true );
define( 'SCRIPT_DEBUG', true );
define( 'CONCATENATE_SCRIPTS', false );
define( 'WP_CACHE', false );

to the wp-config.php file, please? This way, the part that's causing this issue should be displayed as an error message.
Also, please give me access to the dashboard area so I can have a closer look at the settings.
Don't worry, I'm sure that we'll be able to make the website go back to normal in no time.

Thanks,
Radu

June 24, 2019 at 1:46 pm #4077651

andrewL-17

Can we clone the site onto your servers so that you can make all the changes yourself to diagnose the issue? If not, will I basically have to add you as a user with admin settings to my actual site? I just don't want it crashing the original site again.

June 25, 2019 at 10:55 am #4083535

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

We can try to send me a copy of your website and see if I can replicate the issue. All you have to do is have a look at this article https://wpml.org/faq/provide-supporters-copy-site/, create a duplicator package as explained, and give it to me. You can upload it to Google Drive or Dropbox and just send me a link to download it.

Thanks,
Radu

June 27, 2019 at 7:16 am #4097233

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

Can you check the account you created for me, please? I tried to use the credentials you send but they are not working. Can you make sure that you set the right password for my account?
Also, can you attach access to the FTP too? Don't worry, even if I update the plugin and this issue comes back, I'll be able to handle everything in no time. Also, none of the translations will be lost.

Thanks,
Radu

June 28, 2019 at 8:09 am #4105379

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

Can you check the password for your account, please? I tried to use the credentials you send to me but I get a message that the password entered is incorrect.

Thanks,
Radu

June 28, 2019 at 2:37 pm #4108649

andrewL-17

Hey Radu,

I feel like it isn't copying over the user tables correctly and I checked to make sure it was transferred over. Can we use a different website cloning process? With another WPML supporter I used Cloudways. I will copy and paste a portion of that ticket so you understand what I mean.

-----
To troubleshoot this issue without affecting your site I created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

If it is OK with you, we can migrate your content there to further debugging without any risk on your end.

To do the migration please follow these simple steps:
-Install this plugin in your site: Cloudways WordPress Migrator (https://wordpress.org/plugins/bv-cloudways-automated-migration/)
-After you activate it you will be redirected to the migration form
-Fill it with this information:

-----
The rest of the ticket is info that he had set up for me. Can we do it this way? It seemed to work right away when I used Cloudways. I'd just need some guidance on how to do it again with new information that you set up. Thank you!!

July 1, 2019 at 12:10 pm #4118649

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

Can I first have a look at the settings from your website, please? We might be able to sort this out without having to copy the whole website to a different location. I just need access to the dashboard area to check things out. If I'll need to dig a bit deeper, then we'll use Cloudways to copy it on my side (like you did on the other ticket).

Thanks,
Radu

July 2, 2019 at 6:46 pm #4129503

andrewL-17

Please check the last message. I edited it, were you able to log in and resolve the issue? Thanks!

July 3, 2019 at 5:01 am #4131791

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

I managed to access the dashboard area this time. Thank you for that!

I managed to install and activate the latest version of the WPML plugin on your website (with no errors or other issues). Can you check this out, please?

Thanks,
Radu

July 3, 2019 at 4:14 pm #4138097

andrewL-17

Oh, this is great! I'm really glad that my translation strings are back and functional. What was the issue? I'm totally curious as to why it would crash the site.

Also, can I leave this ticket open until around Friday? I just want to be EXTRA cautious with the website and allow the server to automatically backup now that it is functional. I will log in and resolve the ticket myself and make sure I can make changes to the website without error. Thank you very very much, Radu!

July 3, 2019 at 5:28 pm #4138409

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrew,

I'm glad to hear that everything is back to normal now! I just deleted the main WPML plugin and installed again. Nothing special 🙂

Of course I can leave this ticket open until Friday, no worries. You can come back and mark this ticket as resolved if everything works well.

Regards,
Radu

July 6, 2019 at 6:03 pm #4156249

andrewL-17

My issue should be resolved now. I had tested a few saves and it has been functional as of this reply. Thank you very very much!