Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bigul 2 weeks, 4 days ago.

Assigned support staff: Bigul.

Author Posts
July 18, 2019 at 11:14 am #4237943

mikaelG-6

I am trying to: Display a product bundle with variable products limited to only on variation on each product and the output for secondary language isn't working as the translated products doesn't respect the setting "Override Default Selections" under the Bundled Products settings.
In the default language I have set the bundle to contain a specific variation of a variable product. But on the secondary language this setting reverts back to "No default value" (translated from Swedish, so I really don't know the real english phrase for this setting). Which causes the product bundle to display a drop-down menu for each variable product in the bundle on the secondary language product details page.

Link to a page where the issue can be seen: Here you can see the default language output for the bundled product: hidden link
And here you can see the secondary language output: hidden link

And it doesn't matter if I manually change the Bundle Product setting "Override Default Selections" using the WooCommerce product editor. After saving the setting reverts from the variation I set to the default "No default value".

So I would really appreciate if you can fix this issue asap.

July 18, 2019 at 4:01 pm #4240671

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 18, 2019 at 5:42 pm #4241545

mikaelG-6

Hi.
I am sorry, but I don't want to give away access to my site. I gave you clear description of the problem. And either WPML or your plugin WooCommerce Multilingual isn't respecting the settings at the checkbox "Override Default Selections" for the translated product (product bundle) and any changes to this setting directly in the WooCommerce default editor reverts back to "No value" after saving the translated product.

July 18, 2019 at 6:13 pm #4241707

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I will check about this with our team. So one request. Please share a couple of screenshots of Product settings(the one having the issue) for a better understanding of the issue.

--
Thanks!

Bigul

July 21, 2019 at 1:09 am #4250633

mikaelG-6

Hi.

I will get back with screen shots in a couple of days, as I am currently on vacation.

I can also add in the meantime, that the plugin developer of Product Bundles (SomewhereWarm) said that the issue is with WooCommerce Multilingual and that you are welcome to reach out to them for further assistance to make sure your plugin is fully compatible with theirs as you advertise here: https://wpml.org/plugin/woocommerce-product-bundles-2/

Best regards,
Mikael

July 22, 2019 at 2:02 pm #4258261

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

Thank you for the updates. As a part of our compatibility escalation procedures, I have tried to reproduce the issue in the test installation. But not able to reproduce it exactly(maybe not much familiar with Product Bundles). So I have created a test site in our Sandbox server. Please check the following URL.

hidden link

It is a fresh installation. Please configure WPML & WooCommerce like your live site and check the bug is replicable or not. It will help us a lot. We can forward it directly to our developers for further debugging.

--
Thanks!

Bigul

July 22, 2019 at 2:49 pm #4258883

mikaelG-6

Done.

I did it reversed from my own site to save time. So default language is English. Secondary language is Swedish.
So check this product in default language: hidden link

And check it in secondary language: hidden link

As you can see on the default language, there is no drop-down menu below "Size *". If you check secondary language, there is a drop-down for the same product.
You can use the language switcher in the footer to switch between the languages.

Checkout the screenshots from the product setting for the bundled product on the default language and on the secondary language. I have highlighted the setting that isn't being enforced on the secondary language.

Even if you change the setting to the attribute you want to be displayed as only choice on secondary language, it reverts back to "No default Size" after saving.

July 23, 2019 at 2:22 pm #4266991

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

Thank you for reproducing the issue. The bug is existing after the initial debugging steps. Therefore I am escalating the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

July 26, 2019 at 8:57 am #4288473

mikaelG-6

Any news on this? Really need this to be fixed.

July 26, 2019 at 1:08 pm #4289769

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

For your kind updates, our compatibility team is currently working on this issue. We will get back to you soon when we have an update from our team. Please wait.

--
Thanks!

Bigul

August 2, 2019 at 9:20 am #4328433

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

For your kind information, the issue is escalated to our Compatibility Dev team for fixing. We will fix this issue with the help of WooCommerce Product Bundles team.

We will get back to you soon when we have an update from our team on this. Please wait.

--
Thanks!

Bigul

September 1, 2019 at 4:05 am #4492005

mikaelG-6

Almost a month and no fix?! This is really bad support from your Dev team. I have payed much money for WPML and WooCommerce Product Bundles and issues like this should be handled promptly, especially when you claim that they are compatible.

September 2, 2019 at 7:17 am #4494935

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

Sorry for the inconveniences. For your kind updates, the issue is happening because of the compatibility conflicts with WooCommerce Multilingual plugin and WooCommerce Product Bundles team. Our developers are currently working on the fix now.

We will get back to you as soon as possible when we have feedback from our team on this. Please wait.

--
Thanks!

Bigul

November 24, 2019 at 5:18 am #5005861

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mikael,

Sorry for the late response. This issue is fixed in the development version of WPML and WooCommerce Multilingual. The fix will be included in the upcoming version of the plugins.

We will get back to you as soon as possible when we have update from our developers about the release. Please wait.

--
Thanks!

Bigul