This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 3 months ago.

Assigned support staff: Bigul.

Author Posts
July 13, 2019 at 1:08 pm #4203543

nikolajK

WPML has completely broken a website im currently developing, that was completely done - except for needing translations.

I installed WPML and all plugins it needs to translate woocommerce, and I started translating pages, products, plugins etc., one by one., from danish to english.

When all done, I started testing both languages, and immiediatly something was wrong:

- Woocommerce cart missed the "go to checkout" button., I could force it to show on danish language via CSS and display: block, but the english translation no.

- I tried putting a test order in English version, and it says "internal server error", without even going to the checkout window. I change to Danish language, and complete the order - but now the Order Complete thank you page is BLANK.

- I disable ALL WPML plugins, and now all issues with Woocommerce persist.

- "My account" page is also completely broken, and only shows the side menu, but no content.

Do I really need to run a back up, and lose all the translations?

July 15, 2019 at 8:30 am #4208227

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

Please visit WooCommerce>>WooCommerce Multilingual>>Stauts and make sure the *WooCommerce Store Pages* are translated to secondary languages. Please check the attached image for more details.

If the issue exists, please share with me the WordPress debug.log (not WPML debug information) for tracking the issue.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] WPML completely broke Woocommerce on Enfold’ is closed to new replies.