This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Yvette 3 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
June 17, 2019 at 3:39 pm #4036723

emmaH-4

Hello,

I already opened a ticket about this issue some time ago, and it was never resolved because it's taken over a month for your plugin to reproduce the behaviour. Here's the original ticket: https://wpml.org/forums/topic/wpml-configuration-resets-spontaneously/

For some reason the original ticket has been closed. I did not close it because the issue wasn't resolved. I posted an update to the ticket on May 13 specifically to update you that I was still waiting for the issue to be reproduced. Please be sure to read the original ticket, as all the most important information about this issue is contained in there!

The issue has again reproduced itself recently – WPML has, without any action on the part of a user, spontaneously forgotten its configuration – and now I have to scramble to restore bilingual functionality on the site before too many customers notice that it's broken.

I've attached a screenshot of the message shown in WP admin when WPML forgets its configuration. It's a major pain in the neck to go through the configuration wizard again and try to remember how precisely WPML was configured so that the site works as intended again.

This time, as per your support staff member Lauren's request, I have a debug log available. However, it's 106.5 MB large because I haven't been checking the site every day to delete it before the issue was reproduced. How do you recommend I get this log file to you?

Thank you.

June 17, 2019 at 3:55 pm #4036811

emmaH-4

It just occurred to me that since the debug log you asked me to generate is stored in a public folder on the server itself, I can just send you the direct URL. Here it is: hidden link

Please be aware that since it is 106.6 MB large, it will take some time to download.

June 18, 2019 at 5:35 am #4040475

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ve read through your older ticket. I think it may have been closed by a cleanup robot.

I understand that you are experiencing a "random" behaviour that you are unable to reproduce at will. I also have downloaded your error log.

These kind of problems are difficult to diagnose if we are unable to provoke the issue. What can help, is if you are able to determine when the loss of configuration happened so that I can see if I can find any clues in the log.

In general, random errors are often/ususally server/resource related. A reset of the configuration of WPML would indicate that the wp-options table field "sitepress-settings" for some reason is being reset.

It would MOST helpful if you were able to do the following:
- reset your log file (it´s too big right now)
- take a database dump of the table wp-options when the system is functioning normally
- when the issue happens again, BEFORE fixing it, take another database dump of the wp-options table
- then go ahead and "fix" the issue
- Note the time you noticed the issue so that we can look at the log output in a meaningful way.
- Also check with your server support to see if there are any other possible server-level reasons around the same time that would affect your site in this way.

If we have the "before" and "after" shot of your wp-options table, we can then see what precisely is the change in the settings which can then give us more information on what coding event could cause this.

Do you agree to the following steps?

June 18, 2019 at 2:37 pm #4044475

emmaH-4

Hi Yvette,

I understand that process – thank you, I'll be able to take care of that the next time the issue occurs, and take those other steps beforehand as well. It might be another week or possibly weeks before this is reproduced again. Is there any way to flag this thread to the robot as "do not close"?

Thanks
Paul

June 19, 2019 at 8:45 am #4049619

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Unfortunately - I am not sure there is. HOWEVER, you can always open a new ticket and reference the URL of this ticket just like you did the last time.

Cut and paste the essential problem from the original ticket into the new ticket.

Include the
- before/after shots of the db.
- the logs around the time of the event
- the approx time that you could tell the issue happened

This will be the best way forward.

July 6, 2019 at 4:52 pm #4156173

emmaH-4

I'm still on track for doing this, just don't have any updates yet. Posting this comment to keep this ticket from closing.

July 8, 2019 at 7:47 am #4159615

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Understood!

July 14, 2019 at 3:46 pm #4205831

emmaH-4

For your information, this phenomenon has just reoccurred. I've been so swamped with other work that I haven't been able to follow your instructions of creating a database snapshot beforehand… so for now, I'll just have to take a moment and rescue the site from its current state and restore the WPML configuration, yet again. Such a nuisance. I wish there was another way to diagnose this…

July 15, 2019 at 7:17 am #4207631

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Me too! Any way to just take a snapshot of that one table (wp-options) when it happens? It should not take that long to do.

July 16, 2019 at 12:04 pm #4220007

emmaH-4

Hi Yvette,
I've had a little time to get organized today and take a DB snapshot of the wp_options table. I'll take another snapshot once the issue reoccurs, before I fix it. Once it reoccurs I'll note the log entries around that time. Once I have all that together, I'll bundle it up for you in a zip file – how/where do I upload this zip file so you can have a look at it?
Thanks

July 17, 2019 at 7:09 am #4226331

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK.

The best way is to respond to use a file sharing service like WeTransfer, Dropbox, Filetransfer...etc

Then, respond to this message and include only the download link since attempting to upload any attachment > 1M onto the forum is not allowed.

The topic ‘[Closed] WPML configuration resets spontaneously’ is closed to new replies.