This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 5 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
May 1, 2019 at 3:30 pm #3718767

emmaH-4

Hi there,

We've been using WPML on our bilingual website for over 3 years – lovechildorganics.com – and it's worked fine, until a few weeks ago. Now, WPML settings are spontaneously getting reset to the "unconfigured" state, such that it prompts you to run the configuration wizard again. This is happening without anyone logging into the site and making any changes.

We noticed this happened the first time when we went to browse the site on April 9th; then on April 26th we noticed it had happened again; and I just checked it today and it's happened once again, sometime between the 26th and May 1st.

When this happens, the site loses its language switcher in the menu, and also the prominently featured blog posts are shown in the wrong language. I get a bit panicky when this happens and try to address it immediately before the client or any customers notice the issue. To fix it, I go through the WPML configuration wizard and answer all the questions to restore its correct configuration. It seems to have remembered that the two site languages are French and English, but it's forgotten about the language switcher in the menu, the site permalink structure, and several other details.

It's starting to get tedious that I have to keep checking the site to make sure WPML hasn't forgotten its settings, and when it has, to restore them.

Has something changed in a recent version of the WPML plugin that's causing the settings to get reset on their own?

Thanks.

May 1, 2019 at 7:52 pm #3719633

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

There is nothing in our recent updates that should be causing this issue. Let's enable the debug log to see if there are any errors showing there that could give us a clue as to why this is happening.

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

If there are no errors there, it would be best to replicate the site in a staging environment so that we can disable all non WPML plugins and set up a default theme to see if the issue is happening in those settings. This will help us to determine if there is a plugin or theme that could be causing this to be happening. If you don't have the option to set up a staging site, please let me know and I'll be happy to setup one for you where we can test to see if this issue is reproducible.

May 6, 2019 at 5:14 pm #3751379

emmaH-4

Hmm, okay, I've followed your instructions and added those lines to produce a debug log. However, since this issue happens randomly and unpredictably, with no action on the part of any user or administrator (as I described above), I now just have to wait for the issue to be reproduced. Once it's reproduced, I'll send you the contents of the log file. I'm a little concerned that the log file is going to grow to a very large size before this happens, but let's give it a go.

May 6, 2019 at 7:16 pm #3752281

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, thanks so much for the update. If the log file does get big, you can simply delete the log file if the issue has not been reproduced. The log file will automatically regenerate once errors are logged.

May 13, 2019 at 12:53 pm #3798379

emmaH-4

Okay thanks. I'm still waiting for it to be reproduced, so I deleted the debug log for now (was 40 MB) and I'll keep checking in. I'll follow up soon as I have something useful for you!

May 13, 2019 at 4:51 pm #3800773

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sounds good, thanks so much for the update.

The topic ‘[Closed] WPML configuration resets spontaneously’ is closed to new replies.